How much oil does your vehicle consume between OCI..

Messages
238
Location
Monterey Park, CA
427 c5r blocked LS1 consumes 1 qt every 1000 miles. I carry a qt of oil in my engine compartment with a funnel and keep it topped up when I get gas. I personally think adding oil is good for my 6000 mile OCI because it freshens it up.
 
Messages
1,251
Location
Akron, OH
1996 Chevy Caprice, run 6500 miles on 4 QT Supertech 5W30 and 1 QT Rislone. Needed a 1 QT top-off at about 5500 miles into the OCI. No idea what oil the previous owner used.
 
Messages
19
Location
Ann Arbor, MI
1994 Escort GT(Mazda BP) with 141,000 just recently made the change to synthetic at 140,000 but noticed no loss on 3000 mile OCI while on dino oil and so far with a litte over 1k on my Amsoil(10w30) I have lost nothing. not too shabby for a 10 year old car with 140k miles [Cheers!]
 
Messages
153
Location
indpls, in
'97 Camaro SS, bored and strocked to 396 c.i. LT1. 485 h.p., 500 lb/ft of torgue. daily driver. 1 qt. every 750-1400 miles depending on weather and weight of oil used. I have tried everything to control the oil useage including rebuilding and ringing the pistons to Z-06 type of rings. Sucks. [crushedcar] But, I love the performance.
 
Messages
1,836
Location
Ky
I have a 1993 Buick Skylark 3.3 V-6 with 156,600+ miles and it uses around a fourth of a quart between changes.I do change the oil with the 3 month,3,000 mile whichever comes first OCI.I have always changed it this way and as long as I can do so I plan on keeping my OCI this way.Some here may say that it is not needed but it sure doesnt hurt either. [Smile] [ June 08, 2004, 12:21 PM: Message edited by: motorguy222 ]
 
Messages
153
Location
indpls, in
Pedaltothemetal, when i was doing oil analysis and doing the oil changes at 5-6K as I recall, My oil analysis's (sic?) were excellent. When I had the engine rebuilt in april '03, for some reason one of the cam lobes was worn down and the roller rockers showed signs of bluing and wear. Nothing in the oil analysis indicated anything like that [Confused] ....I suspect the adding of oil every 1000 miles or so, masked the problem. I too carry a funnel and 2 quarts of oil w/ me. [Wink] How do you like the C5R motor?
 
Messages
238
Location
Monterey Park, CA
quote:
Originally posted by carl97ss: Pedaltothemetal, when i was doing oil analysis and doing the oil changes at 5-6K as I recall, My oil analysis's (sic?) were excellent. When I had the engine rebuilt in april '03, for some reason one of the cam lobes was worn down and the roller rockers showed signs of bluing and wear. Nothing in the oil analysis indicated anything like that [Confused] ....I suspect the adding of oil every 1000 miles or so, masked the problem. I too carry a funnel and 2 quarts of oil w/ me. [Wink] How do you like the C5R motor?
Got over 25000 miles on it in less than 2 years! The motor block is bulletproof. I did break 3 valve spring. REV 1116 double springs. I recent got a whole new set of REV springs, seals, bases, retainers and had them shimmed. It's the new REV 1116 chrome dual springs made in Argentina. It's real quiet now. Hopefully it will last a long time. My cylinder head is from West Coast. My friend who has a C5R blocked ATI has the same problem as you did, plus has spun bearings...no oil pressure. I suspect the worn out cam is incorrect valve spring height. It's surprising because the most reputable builder in Indiana built it. Anyways I like my setup. It's very mild 224/224 .566" 114 MMS cam. My motor was built by MMS.
 
Messages
69
Location
Michigan
2000 Chevy Silvrado 6.0L 75K using chevron 10w30 with 3K OCI. Has CSK but no oil useage to speak of, 4000 mile trip to Montana only used 1/4qt, drove 80 most of the time. [Patriot]
 
Top