Altima 3.5 hesitation.

Joined
Jan 17, 2014
Messages
583
Location
Virginia
Today while on the highway i switched the altima into manual mode and shifted down to 3rd to pass a very slow moving car. It downshifted to 3rd and i floored the pedal. As it got to 3000 rpm it hesitated pretty bad for a few seconds but as it got to 3500 it picked right back up and everything was fine. I was able to get it to do it 2 more times under the same conditions and it did it again but after i let the car sit for a while it wouldnt act up again while I was on the freeway back home. The car has 173000 miles. Ive done all of my general maintenance. The only thing I havent done is plugs but was planning to here soon. The plugs look clean but the porcelain is a brownish maroon color. They havent been changed since about 92,000. The car runs solid otherwise in any condition. Im hoping it was a fluke....
 

Volv04Life

Thread starter
Joined
Jan 17, 2014
Messages
583
Location
Virginia
Ive thought of that but the filter and pump are one unit. That would be crazy expensive. If the filter was clogged wouldnt it do it more often?
 
Last edited:

Volv04Life

Thread starter
Joined
Jan 17, 2014
Messages
583
Location
Virginia
Also no CEL present. I have a modus and it said no pending codes. I also just learned that the fuel system is non-servicable. You just replace the pump if the pressure drops.
 
Last edited:
Joined
Oct 20, 2013
Messages
407
Location
upstate NY
Could be the plugs, I've had a couple cars that had pump/filter combo set up. At some point they fail and kinda of expensive to fix. With me iit happened more often n got stranded on a long trip once, other car was close to home. Neither threw any codes car just stopped after weeks/months of random hesitation.
 

Volv04Life

Thread starter
Joined
Jan 17, 2014
Messages
583
Location
Virginia
Originally Posted By: SLATRON
Could be the plugs, I've had a couple cars that had pump/filter combo set up. At some point they fail and kinda of expensive to fix. With me iit happened more often n got stranded on a long trip once, other car was close to home. Neither threw any codes car just stopped after weeks/months of random hesitation.
Good to know.lol. Im leaning towards the pump since it has almost 200k on it and I had a few hot no starts last week as well now that i think about it. I just hate to change it out when its functioning decently.
 
Joined
Dec 5, 2006
Messages
116
Location
Kansas City
I think this generation of Nissan engines had an issue with ingesting the catalytic converters at high mileage. I know the 2.5s had quite an issue with it and a little bit of googling seems to indicate that the 3.5s can also be prone to catalytic converter failure. I'd keep an eye on oil consumption.
 
Joined
May 10, 2005
Messages
2,063
Location
Jupiter, Fl
In my G35, if I run regular gas, it will stumble right around 3,200 rpm at WOT as it pulls timing to reduce pinging. It has done this since new and might be slightly worse now at 155k miles. I have a higher output version of your 3.5 I thought the front cat issues were primarily in the 4 cylinder cars.
 

Volv04Life

Thread starter
Joined
Jan 17, 2014
Messages
583
Location
Virginia
Originally Posted By: CBR.worm
In my G35, if I run regular gas, it will stumble right around 3,200 rpm at WOT as it pulls timing to reduce pinging. It has done this since new and might be slightly worse now at 155k miles. I have a higher output version of your 3.5 I thought the front cat issues were primarily in the 4 cylinder cars.
The cat issues were on the 2.5. and I havent ran regular fuel since december(btw, it does run like [censored] on 87.I use injector cleaner every month. Sometimes sefoam. Oh, and i cleaned the throttle. I also had to learn the idle relearn procedure....
 
Last edited:
Joined
Aug 20, 2003
Messages
16,664
Location
NE,Ohio
plugs and wires? Try opening the hood somewhere dark and looking.. you are looking for a mini lightning show.
 
Last edited:

ZeeOSix

$100 site donor 2022
Joined
Jul 22, 2010
Messages
29,618
Location
PNW
Originally Posted By: Volv04Life
Originally Posted By: CBR.worm
In my G35, if I run regular gas, it will stumble right around 3,200 rpm at WOT as it pulls timing to reduce pinging. It has done this since new and might be slightly worse now at 155k miles. I have a higher output version of your 3.5 I thought the front cat issues were primarily in the 4 cylinder cars.
The cat issues were on the 2.5.
The cats have been reported to crumble and smoke the piston rings on the 3.5L V6 also, but it is way less preventable than on the 2.5L 4 cylinders. As mentioned above:
Originally Posted By: 90crvtec
I think this generation of Nissan engines had an issue with ingesting the catalytic converters at high mileage. I know the 2.5s had quite an issue with it and a little bit of googling seems to indicate that the 3.5s can also be prone to catalytic converter failure. I'd keep an eye on oil consumption.
 

Volv04Life

Thread starter
Joined
Jan 17, 2014
Messages
583
Location
Virginia
Originally Posted By: Rand
plugs and wires? Try opening the hood somewhere dark and looking.. you are looking for a mini lightning show.
I have coil on plugs. I also have 0 oil consumption. I have a small oil leak from the cam sensors but it never touches the ground. I add maybe a 1/4 of a quart in 5000 miles.
 
Last edited:
Joined
May 25, 2005
Messages
13,776
Location
ROCHESTER, NY
Maybe it needs you to do this WOT a bit more often as a relearn method??? IDK really! Maybe a battery disconnect too and then drive it like you stole it! laugh Can't hurt!
 
Joined
Dec 16, 2012
Messages
1,556
Location
Oregon coast
Have you ever had the ATF changed? IDK if AT Maximas/Altima have tranny filters or not , but it might be time for a fresh one.
 

Volv04Life

Thread starter
Joined
Jan 17, 2014
Messages
583
Location
Virginia
Originally Posted By: asand1
Have you ever had the ATF changed? IDK if AT Maximas/Altima have tranny filters or not , but it might be time for a fresh one.
Ive changed it around 140k. It was extremely brown and watery. I refilled with nissan K matic. Oh, no servicable filter btw.
 
Last edited:

01rangerxl

Site Donor 2021
Joined
Apr 8, 2006
Messages
10,523
Location
Birmingham, AL
I wouldn't rule out a cat being clogged or the honeycomb coming apart, especially at that mileage. My truck had higher RPM hesitation when its precats were clogging up, which eventually turned into detonation and misfiring as it just couldn't move the exhaust. In my case, the symptoms started out gradually and got worse over a period of a couple months.
 
Top