NAPA 41516 Platinum Cut Open (Pics)

Status
Not open for further replies.

BlueOvalFitter

Site Donor 2023
Joined
Feb 28, 2003
Messages
11,838
Location
Cajun Country, La.
R8R0S, I am guessing your F150 has the 4.2 V6 in it, correct? While using this oil filter, or any other brand besides the FL-400S, did your engine have <span style="font-weight: bold">ANY</span> rattles or ticking upon startup?
 

R80RS

Thread starter
Joined
Jun 5, 2013
Messages
992
Location
Wisconsin USA
Originally Posted By: BlueOvalFitter
R8R0S, I am guessing your F150 has the 4.2 V6 in it, correct? While using this oil filter, or any other brand besides the FL-400S, did your engine have ANY rattles or ticking upon startup?
My truck has the 4.6 V8, not the 6, and I've never had any noise at startup. Most of the truck's mileage was on the FL-400S, but on the rare occasion I used another filter, including this one and the Fram Ultra on it now, there was no problem.
 

ZeeOSix

$100 site donor 2022
Joined
Jul 22, 2010
Messages
35,019
Location
PNW
Originally Posted By: MinamiKotaro
Originally Posted By: ZeeOSix
^^^ LOL, who would want to run a full synthetic media oil filter that's only 50% @ 20 microns when they can run one that is 99% @ 20 microns? grin
Because the XPs don't develop holes between the pleats and the media doesn't unravel into a bunch of splinters that go through your oil system.
Ultra with a pin-hole in the media really doesn't mean much when there is only one reported instance IMO. Purolator media tears ... that's definitely an issue.
 
Status
Not open for further replies.
Top