DD-WRT is the best! - Thanks OVERK1LL!

Joined
Aug 21, 2008
Messages
25,050
Location
ON, Canada eh?
Hey Everyone: So as per OVERK1LL's advice I started playing around with DD-WRT on my link-sys router. Wanting to play with the MEGA file I had to go out and purchase another router with more memory. OVERK1LL sugguested that I get an Asus router. I purchased one and put on the firmware and I have never looked back. The router is not only fast, but it's very stable. I have been running without a reboot for 186 Days straight! Way better than the D-LINK junk of the past I had! Thanks OVERK1LL!!!!!!!!!
 
Joined
Oct 30, 2002
Messages
41,146
Location
Great Lakes
Impressive. I have mine on a 7-day reboot schedule, just to clear out whatever the firmware can't. I bought an Asus router for work purposes, but I don't dare mess with the stock firmware on that one.
 
Last edited:

StevieC

Thread starter
Joined
Aug 21, 2008
Messages
25,050
Location
ON, Canada eh?
Thought I might have to reboot it when my ISP changed my cable modem on me, but nope, just plugged it in and DD-WRT was fine with it... I'm gonna run it as long as I can without a reboot to see how far I can get, it's plugged into a UPS too. It's still fast even after this much time!
 
Joined
Aug 5, 2002
Messages
18,863
Location
Silicon Valley
Even better, DD-WRT on a wifi N connection, and use as a repeater from outdoor -> indoor. One router to rule them all. I have a spare WRT160N V1 that supports it unopened in a box (spare) , and 2 running between me and my neighbor, both running DD-WRT.
 
Joined
Oct 30, 2002
Messages
41,146
Location
Great Lakes
 Originally Posted By: dorkiedoode
tomato!
Been using it for over a year now. It still seems to bog down if you throw more than just a little p2p traffic at it. Maybe it's just the router's (WRT-54G) and not firmware's fault...
 

StevieC

Thread starter
Joined
Aug 21, 2008
Messages
25,050
Location
ON, Canada eh?
I loaded the lite version of DD-WRT on my WRT-54G router before buying the Asus one, and it was fine with P2P traffic. Try the DD-WRT on the router before condemning the router. I think others on this board have found Tomato to have the same problem, but not sure...
 
Joined
Aug 5, 2002
Messages
18,863
Location
Silicon Valley
There is only so much processing power on the router, and only so much bandwidth, that regardless of what firmware you use you can only adjust between application performances. The only way to improve non-p2p performance is to throttle p2p down or pay for more bandwidth. BTW, I used to have a Netgear Ethernet card that would blue screen as soon as I start a p2p application that would open more than 100 or so connection. Eventually I have to install the driver from National Semiconductor to fix it. Netgear never seems to bother to update its driver.
 

OVERKILL

$100 Site Donor 2021
Joined
Apr 28, 2008
Messages
47,207
Location
Ontario, Canada
Easy fix for P2P is to turn off the SPI firewall. It consumes massive resources due to the number of simultaneous connections initiated by things like torrents.
 
Joined
May 6, 2008
Messages
549
Location
New Mexico, U.S.A.
 Originally Posted By: OVERK1LL
Easy fix for P2P is to turn off the SPI firewall. It consumes massive resources due to the number of simultaneous connections initiated by things like torrents.
That's a good fix for home routers lacking in processing power. It won't help a box that's filled up its NAT table and stops accepting new connections, though.
 
Joined
Aug 5, 2002
Messages
18,863
Location
Silicon Valley
 Originally Posted By: tropic
 Originally Posted By: OVERK1LL
Easy fix for P2P is to turn off the SPI firewall. It consumes massive resources due to the number of simultaneous connections initiated by things like torrents.
That's a good fix for home routers lacking in processing power. It won't help a box that's filled up its NAT table and stops accepting new connections, though.
If you have only 1 computer using p2p, maybe you can set it to DMZ?
 
Joined
Jun 17, 2005
Messages
4,942
Location
Billings, MT
 Originally Posted By: PandaBear
 Originally Posted By: tropic
 Originally Posted By: OVERK1LL
Easy fix for P2P is to turn off the SPI firewall. It consumes massive resources due to the number of simultaneous connections initiated by things like torrents.
That's a good fix for home routers lacking in processing power. It won't help a box that's filled up its NAT table and stops accepting new connections, though.
If you have only 1 computer using p2p, maybe you can set it to DMZ?
You had better have a darned good software firewall if you do that. P2P spams your IP address to thousands of computers, and many of them have bots or viruses that will try to access your computer.
 

OVERKILL

$100 Site Donor 2021
Joined
Apr 28, 2008
Messages
47,207
Location
Ontario, Canada
 Originally Posted By: tropic
 Originally Posted By: OVERK1LL
Easy fix for P2P is to turn off the SPI firewall. It consumes massive resources due to the number of simultaneous connections initiated by things like torrents.
That's a good fix for home routers lacking in processing power. It won't help a box that's filled up its NAT table and stops accepting new connections, though.
I've actually never encountered that scenario. I have however encountered the former, including router lock-ups that were resolved by disabling SPI.
 

StevieC

Thread starter
Joined
Aug 21, 2008
Messages
25,050
Location
ON, Canada eh?
My SPI firewall is turned on in this DD-WRT and I use P2P software on few computers at a time and it has been fine. The traffic slows down a bit but barely noticeable.
 
Joined
Aug 8, 2007
Messages
786
Location
Indiana, USA
One caveat with DD-WRT is the developers like to fiddle more than they should. Don't upgrade once you find a version that works unless you have a very good reason. I used DD-WRT within the company that I work for and learned very quickly and painfully to make sure I roll out upgrades slowly. I know that general principle applies to any real-world upgrade process but nowhere else have I gotten such an even mix of good and bad builds from a supplier.
 
Top