castrol edge first impressions

Messages
1,774
Location
RI
I'm using the 0w20 in my 07 v6 accord. changed it out today. previous fill was syntec. First impressions are that valve train noise is way down while driving, almost the same at idle as the syntec, maybe a little quiter. the biggest difference i notice is driving. very very quiet. also seems a little more "peppy" and rev happy. so far so good with the edge smile
 
Messages
1,412
Location
indiana
put edge 5w20 and Bosch D+ filter in my wifes 08 escape 2.3l, @ a stop i couldnt tell it was running, and mpgs continue to go up, im OVERLY impressed and im an M1 guy
 

mattd

Thread starter
Messages
1,774
Location
RI
And just a side note, this stuff pours like water when i was filling the car.
 
Messages
1,412
Location
indiana
Originally Posted By: mattd
And just a side note, this stuff pours like water when i was filling the car.
+1, thinnest 5w20 ive ever poured
 

mattd

Thread starter
Messages
1,774
Location
RI
which part the peppy? lol i figured it just seems a little more rev happy i guess i dont know.
 
Messages
35,631
Location
NY
You're not alone Matt, others share similar observations. I was very pleased with how quiet both my vehicles sound with Edge in them. I'm currently using the 0W20 which I'm very impressed with, as well as their 5W30.
 
Messages
2,434
Location
Oconomowoc Wi
I use the 5W30 Edge in my Acura because I am still not sold on 20 weight oils. The 30 weight is lighter then most 30 weights and that is why I use it. So far I am impressed with it. Not sure if it is any better then most other quality syn oils.
 
Messages
2,766
Location
Bend, Oregon
Originally Posted By: mattd
I'm using the 0w20 in my 07 v6 accord. changed it out today. previous fill was syntec. First impressions are that valve train noise is way down while driving, almost the same at idle as the syntec, maybe a little quiter. the biggest difference i notice is driving. very very quiet. also seems a little more "peppy" and rev happy. so far so good with the edge smile
Could it be that its just 'fresh' oil? How many miles were on the Syntec when you drained it? Plecebo... combined with 'new' oil.??? ______________________________________ 2003 Ford Focus (2.3L Duratec) / 92K Mobil 1 5w20EP / 10K +/- / Mobil EP102 filter
 

pbm

Messages
8,884
Location
New York
My local AA has Edge (in both 0W20 and 5W20) right now for $5.99 a quart. Syntec is $4.99. Is there much difference in the 0W20 and the 5W20?
 

mattd

Thread starter
Messages
1,774
Location
RI
had 4300 miles on the syntec. As bad as this sounds, i may drain it for something a little thicker. The car was warm when i first drove it after i changed it, but i dont know what the oil temp was. I ran it to redline to see how the car felt after about 5 mins of running (coolant temp was already up). Above 6k rpms i heard this noise almost like a rattle. I dont know if it was the exhaust shield i was messing with or lack of oil pressure to the valve train. I'm praying it was not the latter. I tested it again after i was driving on the highway for a few mins and nothing but sweet engine sound all the way to 6800 rpms. If it was an oil pressure issue, and insufficient oil pressure was reaching my valve train, shouldnt the oil pressure light be on? Is it possible its too thin for this engine? Or am i just nuts? And i paid 5.99/qt at AAP.
 
Last edited:
Messages
4,574
Location
Merritt Island FL, USA
Originally Posted By: kcfx4
put edge 5w20 and Bosch D+ filter in my wifes 08 escape 2.3l, @ a stop i couldnt tell it was running, and mpgs continue to go up, im OVERLY impressed and im an M1 guy
I agree totally and I'm an what's ever on sale guy. So Ive used a lot of oils. Preferred Pennzoil products, and will still use them but am extremely impressed with EDGE 0W20. Like someone else said "there are too many people saying the same thing for it to be a coincidence". I am a believer...lol
 
Last edited:
Messages
4,574
Location
Merritt Island FL, USA
Originally Posted By: mattd
had 4300 miles on the syntec. As bad as this sounds, i may drain it for something a little thicker. The car was warm when i first drove it after i changed it, but i dont know what the oil temp was. I ran it to redline to see how the car felt after about 5 mins of running (coolant temp was already up). Above 6k rpms i heard this noise almost like a rattle. I dont know if it was the exhaust shield i was messing with or lack of oil pressure to the valve train. I'm praying it was not the latter. I tested it again after i was driving on the highway for a few mins and nothing but sweet engine sound all the way to 6800 rpms. If it was an oil pressure issue, and insufficient oil pressure was reaching my valve train, shouldnt the oil pressure light be on? Is it possible its too thin for this engine? Or am i just nuts? And i paid 5.99/qt at AAP.
It takes a while longer for your oil to heat up after the coolant/AF reaches temp. So keep in mind 5 mins is too soon to ram any car (you care about) to 6K+RPM's. Don't worry man!
 

mattd

Thread starter
Messages
1,774
Location
RI
ok i will just wait until she is good and hot to before i rag on it next time. Any permanent damage done you think? lol I am impressed with how fast the engine cranks when it is ice cold. It cranks like i have been driving it for 30 mins on an ice cold start. Very quiet on start up to and driving.
 
Last edited:
Messages
1,577
Location
Tulsa, Oklahoma, USA
I know this has been said by many people, but I had the same experience with Edge being quieter. In my case, the Edge 10w30 was in it and I took it out to put something else in (leaving it out to save any debate) and the vehicle became less quiet and smooth feeling. Noticeable enough for the better half to notice and comment on it... and she didn't even know what I had done... just noticed it being louder. So I'm in with the believer's about Edge. Especially the 10w30 version.
 
Top