99 Ford Contour turns off. What could be the probl

Joined
Dec 29, 2006
Messages
326
Location
california
My wife has a 99 Ford Contour with 89000 miles on it. We are the orginial owners. 100K tune up was at 84000. Yesterday, while driving the car, the engine stops (Engine stops running). All electrical is working. Car restarts with no problem. Today, she is driving it and same problem. I told her to call the dealership tomorrow and to take it down. Any guess what could be wrong? I would assume that it's not the fuel filter since I would assume that it was replaced at the 100K tune up, if not, it was replaced at 73000. I'm thinking that the injectors could be clogging and they might need servicing. I have never had her injectors clean before. I figured, running good gas and putting in Chemtool in the gas tank every 5000 miles would keep them in shape.
 
Joined
Aug 8, 2009
Messages
193
Location
Mississippi
My 00 GMC Savana did the same thing - at idle or on the highway at 70 mph. I'd be driving along and suddenly the engine wouldn't be running. Then, before I could pull off the road, it would suddenly be running again. Other times, I had to put it in neutral and it would restart without a problem and run fine. No trouble codes, no indication of a problem anywhere. The shop told me it could be the crank sensor, an 02 sensor, MAF sensor, coil, distributor, computer - any number of things, and that I could start replacing stuff and hope to get it right, or wait until it stranded me. Didn't like those options. Eh - since my travel trailer was for sale (and has since been sold) it was time for a more efficient vehicle anyway...
 
Joined
Sep 5, 2006
Messages
19,479
Location
Chicago Area
This should throw an engine code - a check engine light on the dash. Autozone usually will check it for free. Possibly an idle air valve, TPS, fuel pump [or relay or driver], or ignition part. Something that affects all the cylinders.
 

powayroger

Thread starter
Joined
Dec 29, 2006
Messages
326
Location
california
"EGO flat lined at .45 volts and not switching" I assume the EGO is the o2 sensor. So that is what was done. Cost $324.49
 
Top