0W20 for K24?

Joined
Feb 12, 2018
Messages
441
Location
California
Bought a 2005 Accord 2.4l, Gen 7 & K24… I think. Ran it for a couple hundred thousands miles…then bought a 2016 Accord, now have 65K on that. Here in Michigan with road salt other things get you before engine miles.
Anyways I used 0W-20 on both…however, agree with comments on this forum that 5W-30 would be fine. On my 2016 which is GDI, I do plan on switching over to 5W-30 when my 0W-20 stash runs out. I do 6 - 7.5K miles on an oil change with whatever synthetic is on sale…or better yet, clearance!
I run M1 0/40 in mine. If that's an issue, look at the S2K. Recommends 10-30 that's a 2.2L. 2.4L not really different except bigger bore
 
Joined
Dec 24, 2012
Messages
160
Location
illinois
My 06 Accord 4 cylinder-0w-20 from Dec to March winter oil no issue,then run 5w-20 as oil cap in between.Kirkland synthetic I seen the cheapest at 29.99 for 10 quart(2 jug box)
 
Joined
Feb 23, 2007
Messages
8,333
Location
Grand Rapids, MI
For what it's worth, I'm nearing 640,000 miles on my K24, never rebuilt and still runs great. I think you're worrying too much, these engines are near bulletproof. 6-9k changes on bulk dealership oil for the first 570,000 miles or so. Just buy whichever correctly rated 5W-20 that makes the most sense on sale or with rebates and it'll be fine. I've used 0W-20 and 5W-30 in mine as well and can't tell a difference.
 
Last edited:
Joined
Dec 28, 2009
Messages
123
Location
canada
For what it's worth, I'm nearing 640,000 miles on my K24, never rebuilt and still runs great. I think you're worrying too much, these engines are near bulletproof. 6-9k changes on bulk dealership oil for the first 570,000 miles or so. Just buy whichever correctly rated 5W-20 that makes the most sense on sale or with rebates and it'll be fine. I've used 0W-20 and 5W-30 in mine as well and can't tell a difference.
wow 640000 miles! I see in your signature you use pennzoil HM. At what milage did you use HM oil?
 
Joined
Feb 23, 2007
Messages
8,333
Location
Grand Rapids, MI
wow 640000 miles! I see in your signature you use pennzoil HM. At what milage did you use HM oil?
Somewhere near the 575k mark as the oil pan and valve cover gaskets started weeping a bit and to see if it would help some of the consumption. It goes through about 1 quart per 1k miles like clockwork. It doesn't matter if it's city, highway, 0w-20, 5w-30, etc. and using high mileage didn't help either. I suspect the rings may be worn/gummed a bit.
 
Last edited:
Top