Windows 10 PC wont let me copy files to other media

Windows 10 Pro, Dell Optiplex 3050, up to date. Windows Defender and Avast have not found any bugs.

When I copy a folder to either an external hard drive, USB memory stick, or SD card, the following happens:

1. The copied folder shows up on the external drive, USB memory stick, or SD card,, but it tends to contain only some of the files from the original folder and most of the subfolders are empty.

2. The copied files may at first appear present, but after ejecting the external hard drive, USB memory stick, or SD card, the files may disappears from either the copied main folder and/or the subfolders.

In other words, I copy a folder containing files and subfolders to external drive/storage. Neither files nor folder content remain on any external drive/storage after ejecting the medium. The copied folder and subfolder are empty.

I have never before encountered this madness.

Any ideas?

Had this happen with 1 sd-card. tried multiple times to copy sat nav maps and data on to it but failed. I switched to another card and it worked flawless.