Windows 10 - can't burn CDs now?

Feb 27, 2018
Tried making a mix CD in iTunes like I do every other week and it would get about halfway thru the burn then it would say it failed and eject the disc.

I tried again but with a CD-RW this time instead of a CD-R and it failed again, and when I went to try to erase the disc it said I didn't have sufficient rights to do so.

I also noticed I tried opening my internet browser and it was taking forever to load, but when I disconnected my CD drive it opened instantly.

What may be the trouble?
CD drive has gone EOL?
That's what I initially thought, but I tried erasing the disc with CDBurnerXP program and it worked just fine so it's something on the Windows side of things.

I do have another CD drive so I tried using it with a different disc and tried burning a CD in Windows and it told me I didn't have the rights to do so again.
what files are you trying to burn?

try copying them all to another directory and then burning.. like a folder on your desktop for example.