2003-2008 Corolla cold idle rpm

Joined
Jan 27, 2011
Messages
1,130
Location
Roseville, CA
I have become accustomed to the fact that my wife's 2004 Corolla idles at ~2000 rpm on cold starts, which is pretty annoying because of noise, slamming the tranny in gear at 2000 rpm and the safety hazard posed by it's tendency to pickup speed then upshift - you really have to be on the brakes at all times. About one month ago, I cold started a friend's 2007 (or 2008) Corolla and while it initially shot to 1800rpm it droped to a relatively pleasant 1500rpm after about 2 seconds. Which got me thinking, is there a problem with my wife's Corolla or is it the generational change (in 2005 they went to DBW)? The primary intent of this thread is to survey the Corolla owners here about their experienced cold start rpms. Please mention model year.
The secondary intent is to address the suspected issue.
 
Joined
Dec 3, 2013
Messages
543
Location
ChicagoLand USA
my sister's 2006 starts like that but does kick down a bit after warming...I'd bet you've already done this but clean MAF and intake???...air filter clean???...spark plugs relatively new???...battery at full capacity???...

good luck with yours,

Bill
 
Joined
Oct 3, 2010
Messages
2,295
Location
RI
If you find no mechanical issues call the dealer and see if there is s software update available to address this issue.

That being said, just about every Toyota I have seen of that vintage does that.
 
Joined
Jan 24, 2008
Messages
12,848
Location
OH
Do the rpms drop down to 1100 or so when putting it into drive or reverse? Our 05 Matrix would have high idle but drop down when putting it in gear so the trans wouldn’t slam. It had drive by wire. Cleaning the throttle body and the idle air control valve should lower the idle so it doesn’t change gears on its own when in drive.
 

zorobabel

Thread starter
Joined
Jan 27, 2011
Messages
1,130
Location
Roseville, CA
That being said, just about every Toyota I have seen of that vintage does that.
Thanks for mentioning this.

To answer some other questions:
TB and MAF were cleaned while changing the intake manifold at 165k almost 5 years ago.
Battery was replaced at 189k about 3 years ago.
Air filter was replaced at 187k, plugs at 202k.
Once warmed up and out of gear, it idles at ~700rpm (smack down in middle of the 650-750rpm range mentioned in the manual).
I never cleaned the IACV, not sure it's an issue as warm idle is pretty stable.
LTFT seems about +2.5% at idle.

@SatinSilver This non-dbw car drops the revs to about 1100rpm when cold, right when it slams into gear :(

Shouldn't a dirty IACV result in less rpm, not more?
Starting the car with the IACV disconnected results in a rough low idle when cold, putting the trans in gear almost makes the engine stumble. Once warmed up things are good, except for the pesky CEL.
 

Similar threads

Top