2 Fram PH5s cut open w HPL EC30

wlk

Joined
Aug 21, 2016
Messages
477
Location
Pennsylvania
Here are 2 PH5s from my 93 C1500 5.7l running QS blend HM 10w40 and HPL EC30. Filters have 36 even pleats, silicone ADBVs and filter material is right at 42"long. 1st filter has 1382 miles on it. Only saw one little piece of crud in the pleats but down in bottom looks like, what I would assume to be some liquefied sludge and varnish. Second filter has just over 2k miles on it-forgot to write down the exact miles, it does have some of the dark sludgy looking residue in the can but I did punch a hole in the side of the filter and let it drain as the first one took forever to drain the oil from the pleats. It may have had the same amount but I will never know. One thing I have noticed the motor has developed a valve cover gasket leak on the driver side at the rear of the motor. So maybe the EC cleaned up some goo that was plugging the leak idk 🤷. Will have it fixed when I get the truck back from my son. Also noticed some oil seepage around the PCV and Breather grommets in the valve covers, one on each side.
IMG_20220927_150846_752_kindlephoto-381576048.jpg
IMG_20220923_174748_860_kindlephoto-229460670.jpg
IMG_20220923_174807_178_kindlephoto-381380918.jpg
IMG_20220923_174819_628_kindlephoto-381416247.jpg
IMG_20220923_174838_183_kindlephoto-381451526.jpg
IMG_20220927_151427_618_kindlephoto-381899327.jpg
IMG_20220927_151449_974_kindlephoto-381959757.jpg
IMG_20220927_151525_321_kindlephoto-382012090.jpg
IMG_20220927_152000_504_kindlephoto-382371181.jpg
IMG_20220927_151936_031_kindlephoto-382503368.jpg
 
Last edited:
Top