Wheel bearing for Chevy Impala

Joined
Dec 16, 2009
Messages
106
Location
Rhode Island
I had replaced the rear passenger side with a Timken bearing/hub unit about 7,000 miles ago. Today it catastrophically failed without warning while doing about 50 MPH downhill (bang, grinding, smoke, etc). I got out and checked everything and saw no tire damage and the brakes weren't overhearing so I limped it at slow speed about 5 miles to my destination. Apparently it was so bad that the tire was able to rub the bottom of the strut tower from the car lowering at that corner as the bearing chewed up. I now need a new tire and bearing/hub, along with whatever else I find damaged.

Any recommendation on replacement wheel bearing/hub brand for a 2013 Chevy Impala? There are many brands listed on Rockauto (Mevotech, Centric AcDelco, Timken, Moog, SKF). I usually trust Timken bearings but I'm second guessing after this.

Pictures of this mess to follow once I tear into it tomorrow.
 

WA1DH

Thread starter
Joined
Dec 16, 2009
Messages
106
Location
Rhode Island
Well it looks like I jumped the gun on the diagnosis. The wheel bearing was just fine. The base of the strut tower rusted through letting the car drop onto the wheel. I've never seen anything like this before. There doesn't seem to be any drainage in the base so I would guess years of salt spray sat in there and rusted it out. I will go ahead and replace both rear struts to be safe. The fronts look less rusty. I should probably replace the tire while I'm at it :rolleyes:
 

Attachments

  • 20210627_082454.jpg
    20210627_082454.jpg
    125.7 KB · Views: 38
  • 20210627_083242.jpg
    20210627_083242.jpg
    107.8 KB · Views: 38
  • 20210627_083252.jpg
    20210627_083252.jpg
    98.7 KB · Views: 38
Top