Some mouse buttons not working properly

Oct 30, 2002
Great Lakes
This started happening just the other day, possibly after the most recent W10 update.

Buttons 4 and 5 (side buttons) on my mouse used to act as "forward" and "back." Now whenever I press one of these buttons, it just opens an page and the Windows calculator. I tried uninstalling the mouse - no help. I also used a third party mouse configuration utility (X-Mouse Button Control), but it doesn't seem to make any difference either.

The mouse itself didn't come with any management software.

Is there a way to fix this?
Last edited:
You could roll back/restore to your most recent backup before the win10 update, then disable that specific one you determine causes it, but what mouse?

If I was depending on more than left/right click, it's going to have supporting software. Maybe the manufacturer makes that and you just don't have it yet, check their website?
It's some no name mouse, iClever brand. Now that I recall, the first one I bought about a year ago had this same issue from the start, so they sent me a replacement right away. It worked fine for a year before this happened.