Rattle at start up, 2011 Regal 2.4

Messages
3
I bought my 2011 regal 2.4 about 3 years ago. After the first oil change I noticed a rattle noise at start up only. For the life of me I couldn't figure out why. I started reading about it and found out it's a common problem. Some recalls too but my vin was not on recall.
To get to the point, the oil filter was the problem. I tried the best Fram and a few other brands but still rattle every so often.
I decided to go with A/C Delco after the dealer recommended it. Well sure enough so far after 3 oil changes no rattle. I found out that most oil filters have a metal barrier inside with holes for the oil to go through. That barrier was restricting the flow and not letting oil reach to the furthest parts of the engine. The ac delco has a fence type barrier that allows maximum flow, that was it.
 

Zee09

Site Donor 2021
Messages
4,798
Location
Fairhill Maryland
Very free flowing indeed
 

Attachments

  • ST3614006.jpg
    ST3614006.jpg
    66.9 KB · Views: 24
I’ve always used OEM filters: Ford, Honda, GM, BMW and now Kia (Hyundai). Never a problem (that I’m aware of) and priced reasonably as well. Buy them at the dealer and use the invoice (along with the oil purchase receipt ) to record the oil change. I’ve never had a warranty claim but if I ever do I hope my system works well enough to keep me in the clear.
 
Messages
1,741
I bought my 2011 regal 2.4 about 3 years ago. After the first oil change I noticed a rattle noise at start up only. For the life of me I couldn't figure out why. I started reading about it and found out it's a common problem. Some recalls too but my vin was not on recall.
To get to the point, the oil filter was the problem. I tried the best Fram and a few other brands but still rattle every so often.
I decided to go with A/C Delco after the dealer recommended it. Well sure enough so far after 3 oil changes no rattle. I found out that most oil filters have a metal barrier inside with holes for the oil to go through. That barrier was restricting the flow and not letting oil reach to the furthest parts of the engine. The ac delco has a fence type barrier that allows maximum flow, that was it.
Hate to bust your balls but my guess is it’s not the oil filter. I’ve owned a few of these Ecotec engines and oil filter brand didn’t make a difference, even the OE Hengst filter. The tensioners on these are prone to getting gunked up from sludge, varnish, or carbon deposits in the oil. Your best bet is to not let sludge and varnish build up in these engines
 
Messages
5,763
Location
Da Swamp
My 2011 didn't rattle, but it consumed oil a bit later in its life. I bought it in early 2014 with about 40K miles on it. At around 60K the oil consumption began, and seemed to continue no matter what oil I used. It didn't seem to smoke when I drove. There was something about the PCV system -- apparently it's not a simple valve to change, it's integrated with the manifold. You might want to check the oil pretty frequently.
 

Markpups

Thread starter
Messages
3
Hate to bust your balls but my guess is it’s not the oil filter. I’ve owned a few of these Ecotec engines and oil filter brand didn’t make a difference, even the OE Hengst filter. The tensioners on these are prone to getting gunked up from sludge, varnish, or carbon deposits in the oil. Your best bet is to not let sludge and varnish build up in these engines
I'm so paranoid about this engine, I've been changing oil every 1000 mi so there's a good chance there is no gunk build up. I started doing this around 45,000 and I'm at 90,000 now and everything is perfect except I noticed a half quart missing every 1000 mi. Again I've been rattle free for about 10,000 mi now using walmart 5/30 syn.
 

Markpups

Thread starter
Messages
3
I'm so paranoid about this engine, I've been changing oil every 1000 mi so there's a good chance there is no gunk build up. I started doing this around 45,000 and I'm at 90,000 now and everything is perfect except I noticed a half quart missing every 1000 mi. Again I've been rattle free for about 10,000 mi now using walmart 5/30 syn.
And ac delco filter.
 
Messages
2,253
Location
London, England
I'm so paranoid about this engine, I've been changing oil every 1000 mi so there's a good chance there is no gunk build up. I started doing this around 45,000 and I'm at 90,000 now and everything is perfect except I noticed a half quart missing every 1000 mi. Again I've been rattle free for about 10,000 mi now using walmart 5/30 syn.

Just signed up and saying they have been changing the oil every 1000 miles.....
 
Top