Oxygen sensor replacement on '01 Pathfinder

Messages
918
Location
Florida, USA
I have a P0158 code (bank 2 sensor 2 [driver's side post-cat] high voltage) on my Pathfinder. It has nearly 130k miles and the sensor is original. The sensor is OEM, and it says Bosch on it. Can I buy this universal Bosch sensor and splice it in? I'd solder and use electrical tape, then use heatshrink over the individual wires, then a couple larger tubes of heatshrink over the whole wire bundle. I don't see the point in paying $30-40 for a connector and a few extra feet of wire when I can just do a decent job splicing a universal sensor in instead.
 
Messages
36,526
Location
ME
I've had good luck with their one-wire universals, so expect good results from a 4-wire as well.
 
Messages
26,149
Location
MA, Mittelfranken.de
Quote:
I'd solder and use electrical tape, then use heatshrink over the individual wires, then a couple larger tubes of heatshrink over the whole wire bundle.
Never solder O2 sensor wires, the O2 breathes ambient air through the wire strands. Very early units had a vent hole but modern styles (the ones on this vehicle are modern) do not and will choke if blocked by solder. Bosch universals are iffy at best, we had nothing but bad luck with them. Look for a OEM fit from Denso at Rock Auto, its a lot less trouble in the long run.
 

Towncivilian

Thread starter
Messages
918
Location
Florida, USA
Originally Posted By: Trav
Quote:
I'd solder and use electrical tape, then use heatshrink over the individual wires, then a couple larger tubes of heatshrink over the whole wire bundle.
Never solder O2 sensor wires, the O2 breathes ambient air through the wire strands. Very early units had a vent hole but modern styles (the ones on this vehicle are modern) do not and will choke if blocked by solder. Bosch universals are iffy at best, we had nothing but bad luck with them. Look for a OEM fit from Denso at Rock Auto, its a lot less trouble in the long run.
An OE fit Denso is about $63 on Rock Auto. Still a lot better than paying through the nose for one from the dealer, I'll consider it. Thanks for the info about soldering the wiring. Using butt connectors wouldn't be as durable, I think. Maybe a universal one isn't the greatest idea, then. If the original O2 sensor is Bosch, why would another Bosch cause problems? What about an OE-type Bosch O2 sensor, which is about $53 after AAP discounts? FWIW, a customer review with an '01 Infiniti QX4 (counterpart to my Pathfinder) says it worked perfectly and looked exactly like the original.
 
Messages
26,149
Location
MA, Mittelfranken.de
Nothing wrong with OEM Bosch if you can get one at a good price. The replacement Bosch i have seen are not the same quality as the OEM Bosch from the dealer, the wiring seems a little more universal to fit more vehicles, there sure is a price difference. The Denso units are excellent quality with high quality wiring harness and connector, it fits right. Both will work well, your decision.
 

Towncivilian

Thread starter
Messages
918
Location
Florida, USA
I think I'll try my luck with the Bosch OE-type sensor which I can get for $50 after coupons at AAP locally. There's a 1-year warranty if it's defective. If it fails I'll probably try the Denso sensor. I presume I'll need an O2 sensor socket. I have PB Blaster to help loosen the plug. Do I use anti-seize? I have some copper anti-seize, is it ok to use?
 
Messages
965
Location
San Antonio, Texas
You don't necessarily need an O2 socket if you can get a normal 7/8 wrench on it. Disconnect the O2 electrical connector, run the end through the box end of the wrench. Once the box end is on the sensor tap it a few times with a hammer. It should loosen right up.
 
Messages
26,149
Location
MA, Mittelfranken.de
For $50 you cant go wrong IMHO. Like i said i don't care for the universals basically because of connection issues ,the direct fit seem okay. As you say it has a guarantee and AA is good about exchanges, Chances are it will come with a small packet of anti seize but if not the copper is good. Soak it good with the PB overnight before going after it, as someone posted a regular box wrench may work but if you need some real grunt on it get a good O2 socket with 1/2" drive. Lisle has some decent ones at Sears. This one works real well. http://www.toolking.com/lisle-12390-dual-drive-oxygen-sensor-wrench?gclid=CNqN8PWMg6wCFeQ65Qod2VLNKw Edit: Fix link
 
Last edited:

Towncivilian

Thread starter
Messages
918
Location
Florida, USA
Thanks for the info everybody. I chatted with some other Pathfinder owners and they say the O2 sensors generally come right out without much fuss - PB Blaster should be all I need. I will try a box wrench, failing that I'll acquire a socket somewhere.
 
Messages
36,526
Location
ME
Remember you're cutting the wires so if the connector is too big to fit through the box of the wrench, go for broke. You may not even need the PB, it'll smell burning off the exhaust, harmless, yet possibly annoying.
 
Messages
14,670
Location
The Old North State
Originally Posted By: Towncivilian
I think I'll try my luck with the Bosch OE-type sensor which I can get for $50 after coupons at AAP locally...
OT Just curious what AAP code/coupon you used to knock the price down to ~$50? Recently purchased OE Denso air/fuel ratio sensor for a Tacoma, Amazon had the best price with RA close. Looked at AAP and a code, but couldn't come close with current codes and AAP price.
 

Towncivilian

Thread starter
Messages
918
Location
Florida, USA
I used code VISA. I just finished replacing the O2 sensor. It came out pretty easy with the help of a light hammer tap, no PB Blaster needed. The hard part was removing all the clips that secure the wiring harness - there were five of them. Three were in the engine bay and not too difficult to rip out, but two of them were between the transmission bell housing and ... some other large immovable item in the way, which didn't give me much room to fit wire cutters into to snip the clip. I ended up cutting the wiring harness of the old O2 sensor near the connector in the engine bay to remove it easily. The new O2 sensor had some grey anti-seize applied already, so that's what I used. My 1/2" drive torque wrench's head was too large to work around said immovable item in the way, so I had to settle for using the 1/4" drive torque wrench which goes up to 200 inch pounds (~17 ft pounds), but the torque spec is 30 to 44 ft lbs. I'll have to see if I can get it torqued at a shop tomorrow. All in all it took somewhere around 2 hours but my buddy and I started this when it was already dark - I guess we just like to challenge ourselves. I haven't driven the vehicle yet, but starting the engine and revving a bit didn't result in a CEL so far, and I don't hear any exhaust leaks.
 
Messages
26,149
Location
MA, Mittelfranken.de
Good to hear you got it out, i didn't see you were in FL that makes a huge difference. In the rust belt nothing comes apart easy. I have to do an O2 on a 96 Subaru this week and i know its going to need torches and breaker bar. Don't bother torquing the O2 it uses a crush washer like a spark plug, just snug until the washer is firmly crushed like a plug is fine.
 

Towncivilian

Thread starter
Messages
918
Location
Florida, USA
OK, I'll leave it as is. It's pretty snug so I'm sure it'll be fine. Next time I replace an O2 sensor it'll be during the day... Thanks everyone! And good luck with the Subaru, Trav! smile
 
Top