First Post - First real piston soak

RapidCAD

Thread starter
Joined
Mar 5, 2018
Messages
14
Location
Michigan
Originally Posted By: 1JZ_E46
All of those caustic chemicals are probably making your problem worse. They are not friendly to aluminum. You are literally eating away your pistons.
Perhaps you are right but I doubt it very much. With all the posts I've read here I would have thought that would have come up. Besides, I did NOT say things got worse since the soak, I said some things got better. I don't believe my pistons are aluminum, and if Kreen or B-12 eats steel or aluminum , they would ship in a plastic container. All that I am saying is that the oil consumption has not been reduced much by the soak and flush attempts, but the compression numbers have improved noticeably.
 

RapidCAD

Thread starter
Joined
Mar 5, 2018
Messages
14
Location
Michigan
So instead of running the Kreen in the oil the full 1000 miles, I decided to change the oil today and get her ready to sell. That oil was quite black after 500 miles with the Kreen in it. Man was the head clean when I checked the baffles! However when I got the oil topped off and took it for a short spin, she smoked a lot longer than usual, streaming smoke for about a block under medium throttle. It did finally clear up and seems fine. That raises a question. So I just put all that oil in the valve cover, does the smoke indicate a valve stem seal problem? Those seals are only 9 months old (Medvotech) installed by an engine rebuilder. Would smoking like that indicate bad valve guides? With my compression number so good I'm starting to question the valve train. She clatters like a diesel every time you start her after she sits 2 days or more. Anyone know?
 
Top