05 Express 3500 brakes weak

Messages
3,373
Location
Kansas, USA
Now that it's warming up need and the RV trips is about to start better figure this out. Back story is it's a 05 Chevy Express 3500 28ft with 77k, we got 8 years ago at 26k so I know all the brakes are original. I have flushed the fluid on a yearly basis and pulled the lubed the pads twice. Over the last year the brakes don't seem to "grab" like they used to. From what I can tell with the wheel on looks like 1/2 pad is left, going to pull the wheel this week and take a closer look. The brake pedal does have a bit more travel than I can remember. Also despite alot of flushes the power steering whines for quite a while till it warms up. Initially had Maxlife but changed it out for just power steering fluid. Since it has hydroboost if I hold down the brake pedal and turn the steering wheel you can feel the pressure changes in the brakes, maybe normal?

It does pulsate when the brakes heat up (started last year) so I'm going to replace the front pads and rotors regardless. But I'm starting to wonder if I don't have a hydroboost issue starting.. or maybe I'm overthinking it. No leaks from either the brakes or power steering.
 

Eric Smith

Thread starter
Messages
3,373
Location
Kansas, USA
No one responded and that's ok. Lots of pad left and rotors look ok. Found most likely most of the issue.. bad wheel bearing on the passenger side. Never made a peep but at least 1/8 inch play. New ac delco on the way.

C5368C1D-40E0-4E75-AA02-562C23835067.jpeg
 
Messages
34
Location
MN
Had 05 Express 1500 with hydroboost and weak brakes and it ended up being sticky/rusty caliper slides and one seized caliper piston. Replaced all calipers and the van stops like new. Another thing to consider is the soft lines.
 
Top