wpa2, security and settings

Not open for further replies.


Staff member
Dec 14, 2002
New Jersey

So I got the Asus 520GU router, and flashed DD-wrt onto it. It works, and I am typing on it right now.

I enabled WPA2-personal and AES, and it works fine on my mac. However, on my SP3 toshiba laptop, no connectivity... I then set it to AES+TKIP, as some claimed that this would make it work. XP recognizes that the connection is WPA2, and queries me for my code, but it never actually finishes acquiring a network address.

My guess is that the drivers for the network card are not allowing correct connectivity.

So, what is my best bet? Do I do WPA2 personal mixed-mode? This supposedly allows WPA connections on, and enables greater connectivity with all sorts of devices, but doesn't this just re-open a security issue on my router?

I'll have to verify also on other pieces of equipment, but what is the best bet given this apparent issue? I can use hardwire when the computers are in the room with the router, but this limits portability.

Any suggestions or comments?


on another note, with this G router, I am able to turn output power down to 25 mW from the default 70, and still have a real strong signal everywhere. Ill try to optimize it so the signal is only reaching within my home, which is great.
You may have to setup the connection profile manually and not via the "Available Networks" list.

In other words, you won't be able to click on your network in the list and click "Connect" with your supplied WPA key.

You may have to go in and configure a profile for your network with the SSID/WPA2 key etc...

I'm signing off for the night, but will check back tomorrow to see how you made out...
Overkill is right. I would search the net for an updated driver for the Toshiba wifi card. I had to do the same for my Toshiba satellite Laptop. It would only go up to WEP encryption. I found a driver online. Installed it, then I could go up to WPA. This was last year.
I think it is the WPA2 personal mode that you should choose on the router. I have seen a few NIC work only in WPA2 personal but not the WPA2 enterprise.
The card is an Intel(R) PRO/Wireless 3945ABG. Claimed by intel to be WPA2 compatible. I have my router in WPA2 mixed personal mode, and my WPA acces point is able to communicate.

No setting for the connection in XP allows me to connect to the router - Ive tried all options. Vista works fine.

My router is set to WPA2 personal mixed with AES and TKIP selected (option to select both).

Any suggestions?

Also, what security issues do I have given my selection of the personal mixed mode (which seems to allow WPA items to connect), and using both TKIP and AES enabled?

By the way, updated to the latest drivers this morning before doing all of the tests.

ALso input all of the information manually.
And to make it worse or more annoying, just fired up my IBM thinkpad T42 from 2004, and it was set up and able to do WPA2 no problem - put in the info and I'm typing this now.

The thinkpad hasan IBM configurationprogram to save WiFi settings. The toshiba just uses thestandard windows configuraton - perhaps that is part of it?

Sad that a mid-2004 laptop does it nearly instantaneously, all my other hardware works, and I cannot make connection with a late-2008 xp laptop that was within days of when they would NOT be selling XP-equipped laptops anymore!
Intel has a program called ProSET, it is available on their website and is available with the most recent drivers as a bundle.

Grab that and give it a try.
Did it. No dice.

Ive tried all the options... with no dice. The proset driver doesn't offer much in terms of security options unfortunately - I still have to enter the WPA2 codes through the WIndows XP wireless configuration thing.

Stinks - no indication why I cannot get it to work either... Just tries to acquire the network address, then stops and goes to another router that it can actually get one from...
making it more annoying, again, booted into XP on my macbook pro, went to connect, added my WPA2 code and done.

Typing from it as well.
Finally got it to work on the toshiba. Disabled Symantec Endpoint Protection (combined firewall, AV, etc.), and tried again - it worked.

So now I need to figure how to set the symantec to allow this to work...
Symantec products are nothing but a big PITA that hog way too many resources on your system. I would take Tim H. advise and uninstall it and go with something better like ESET Smart Security.

You won't be sorry!
Not open for further replies.