Rough Idle/Dimming lights

Messages
19
Location
Puerto Rico
I have a rough idle that comes and goes. It does not do this with certain conditions met somedays I can race her, turn AC on, music on high, lights on and everything is fine. Other days the lights flicker, revvs go low and it seems like the engine is about to stall. (It has never stalled though)If it helps where I live temperature rarely goes below 76F and average is supposed to be 86F but between 11AM-4PM with traffic temperature goes easily into the 90'S What I have tested/done: The engine and trans mounts are new. Battery has about 8 months, it's a Yellow Top AGM, voltage is ok. I changed the IAC valve which helped the issue. EGR valve and the tube are in working condition and clean. ECT, MAF, and IAT sensors give good readings. Temperature never goes over 192F. Vacuum is always between 19 and 21. LTFT (Long Term Fuel Trim) is always below +/- 2% when idle. Fuel and Air filters have been changed in the last year. TPS reads 14.5% at idle but it seems to be the norm. I exchanged with a vehicle with no problems and a new TPS and the reading was the same. Now to the things that I haven't tackled. Both O2 sensors switch actively, should I changed the either way since I am over 100K and they are original? Ignition Coils are originals and didn't find a way to test them. Same as O2 sensors, should I change them because of mileage and weather? Haven't tested fuel system at all since I don't have the tools.
 
Last edited:
Messages
877
Location
Reno, NV
Considering where you live, my first check would be any and all electrical connections may have become corroded, especially grounds.
 

BumpLover

Thread starter
Messages
19
Location
Puerto Rico
The alternator has about 20k miles in, an AutoZone replacement since the original one did get FUBAR. Will check the electric AC fan to see if I see anything abnormal with it.
 
Top