Old motor mount Pic( Focus)

Joined
Jan 3, 2009
Messages
14,892
Location
Illinois
This pic shows the old MM. If you look carefully you can see where some of the fluid came out.
 

tig1

Thread starter
Joined
Jan 3, 2009
Messages
14,892
Location
Illinois
Originally Posted By: Miller88
Have you tried to start the car while at a stoplight yet? Such a huge difference!
Purrs like a kitten.
 
Joined
Sep 20, 2011
Messages
169
Location
Kansas City
I've noticed mine making a lot of vibrations in the dashboard that didn't used to be there. The mount didn't look bad, but obviously that appears to be the underside and wouldn't be visible without removing it. I've read on several sites that the mounts on these cars are chronic failure points with enough age/mileage. Thanks for the post and the pic. My '06 Focus is at 90k and so far has been fairly trouble free. One split halfshaft boot, one valve cover gasket, a new set of plugs and a serpentine belt tensioner so far. Not too bad.
 

tig1

Thread starter
Joined
Jan 3, 2009
Messages
14,892
Location
Illinois
Originally Posted By: chestand
I've noticed mine making a lot of vibrations in the dashboard that didn't used to be there. The mount didn't look bad, but obviously that appears to be the underside and wouldn't be visible without removing it. I've read on several sites that the mounts on these cars are chronic failure points with enough age/mileage. Thanks for the post and the pic. My '06 Focus is at 90k and so far has been fairly trouble free. One split halfshaft boot, one valve cover gasket, a new set of plugs and a serpentine belt tensioner so far. Not too bad.
My 2007 Focus has been very reliable as well. Alternator, serp belt, Front rotors and pads, and now the MM. Actually this is the top view which is hidden by the other part of the MM. Can't see this side until removed.
 
Last edited:

tig1

Thread starter
Joined
Jan 3, 2009
Messages
14,892
Location
Illinois
Originally Posted By: CT8
That is the one on the front of the engine? passenger side.
Yes. Top passenger side.
 
Last edited:
Joined
Sep 23, 2008
Messages
10,031
Location
Ontario, Canada
A few years ago at an autocross, a mazda3 popped that mount and it took us a while to figure out where all this fluid had come from? I hadn't even really heard about a fluid filled mount before then.
 

CT8

Joined
Oct 9, 2014
Messages
15,387
Location
Idaho
Thanks was the job eady? We have a 2010 Focus in the family. it is a really nice car in my opinion.
 

tig1

Thread starter
Joined
Jan 3, 2009
Messages
14,892
Location
Illinois
Originally Posted By: CT8
Thanks was the job eady? We have a 2010 Focus in the family. it is a really nice car in my opinion.
Yes, with a few basic tools. Hyd.jack, 15 and 18MM sockets, 1/2 dr long extension and ratchet.
 
Joined
Apr 9, 2008
Messages
15,210
Location
Central NY
Originally Posted By: tig1
Originally Posted By: CT8
Thanks was the job eady? We have a 2010 Focus in the family. it is a really nice car in my opinion.
Yes, with a few basic tools. Hyd.jack, 15 and 18MM sockets, 1/2 dr long extension and ratchet.
I was surprised at how quickly the dealer changed mine out. Like 15 minutes.
 
Top