Ok to mix ATF?

Joined
Apr 13, 2013
Messages
8,017
Location
FL, USA
Its a habit of mine to check all the fluids when cleaning a vehicle. So after I was finished cleaning the Uplander I checked all the fluids. Engine oil, full...surprisingly...brake fluid...check, coolant...a little low but ok...power steering fluid, below the "cold" mark. Trans, at the "add" mark. So I went to WM and picked up some Prestone PS fluid and topped it off. Went to get the funnel and filled up the Trans to the full line. I used Valvoine Max Life full synthetic. It says its ok to use for Dex II, III and VI among many others. I figured this would be better than the Super Tech and Castrol. The trans was rebuilt 2 years ago so I am not sure what brand was used. It originally was filled with Dex III but it was still banging into gears at stoplights. Trans shop said maybe it had a newer 06 trans in it so he put in Dex VI. I am assuming all will be well with the two different fluids but I wanted to check with the knowledgeable people of BITOG...thanks in advance.
 
Joined
Sep 12, 2012
Messages
1,981
Location
Greatest Earth on Show, UT
MaxLife is a favorite here on BITOG, especially now that they have the full syn version. You have chosen well. One question on the tranny fluid check: did you do it cold with the engine off or warmed up and engine running?
 
Joined
Oct 28, 2008
Messages
1,710
Location
MD
How do you like your van, by the way? They are reasonably priced used.
 
Joined
Aug 14, 2010
Messages
12,966
Location
Northern Kentucky
Still banging into gears after the rebuild, i contend you got a shoddy rebuild like most shops that just replace soft parts and minimal parts to charge you a full rebuild. Many of them don't want to replace the other parts since you don't need to replace everything to get past the 12 month warranty. You've seen this right? http://tripleedgeperformance.com/4T65E-Common-Problems.html On topic though... The Maxlife is my favorite replacement for any Dexron application. Maxlife full synthetic ATF is a steal if you buy it by the gallon. It's not just for high mileage vehicles, it's great for most anything with a few exceptions.
 

Astro14

$100 Site Donor
Staff member
Joined
Oct 10, 2010
Messages
13,841
Location
Virginia Beach
Fluid will mix, but if it's still banging, you've got a problem. You don't say how you checked the trans level, but if it's cold when you checked, then you added too much....
 
Last edited:

gregk24

Thread starter
Joined
Apr 13, 2013
Messages
8,017
Location
FL, USA
Originally Posted By: ET16
How do you like your van, by the way? They are reasonably priced used.
Its the parents van, but I do most of the maintenance on it. Its a nice van. It was purchased used about 3 years ago. Its the base model, nothing too fancy, but it does have a standard DVD player and some nice touches like faux wood trim and silver painted accents. It dresses it up a little. Its a smooth riding van and is great for long trips. Gets decent MPG. We average 18.5 in it and thats 95% city driving (most trips are literally about 1 miles in length). I have made it up to 29 MPG on the highway driving 65 MPH before. Its had its share of issue though. The engine has pinged since shortly after we got it, cant seem to get to the cause of that issue. Its had suspension work done, tie rods, bushings, and end links. Gas tank sensor went out, temp sensor...the typical GM stuff. Front and rear brakes replaced once so far. Seems to tear up on the tires a bit, but in fairness they haven't been rotated or balanced on a regular basis. The biggest issue to date has to do with the trans. It started on a trip, we were pulling out into traffic from a stop and it would hesitate then slam into first gear..no flare, just a pause then slam. It did that about 3 times in a short period of time. Checked fluid, clean and full. That issue "went away" but returned a year later. Had it checked out and there was copper in the pan, so it had a rebuild. Slamming into first returned so I took it back and they tried a couple things, changed fluid to DEX VI..nope, new higher stall T/C...nope, reset computer a couple times...nope. Finally a new sensor (cant remember which one) was replaced and all has been well since, knock on wood. Now the ABS light comes on intermittently. Sounds like a lot of issues but for 3+ years and unknown previous maintenance I suppose its not all that bad.
 

gregk24

Thread starter
Joined
Apr 13, 2013
Messages
8,017
Location
FL, USA
Originally Posted By: Astro14
Fluid will mix, but if it's still banging, you've got a problem. You don't say how you checked the trans level, but if it's cold when you checked, then you added too much....
I checked it while hot and running like you are supposed too, it was on the add mark. Topped off to the full mark while it was still running. It only took half a quart to bring it from add to full, a little confused about that. Ill check it again soon to verify.
 
Joined
Sep 12, 2012
Messages
1,981
Location
Greatest Earth on Show, UT
Originally Posted By: gregk24
Originally Posted By: Astro14
Fluid will mix, but if it's still banging, you've got a problem. You don't say how you checked the trans level, but if it's cold when you checked, then you added too much....
I checked it while hot and running like you are supposed too, it was on the add mark. Topped off to the full mark while it was still running. It only took half a quart to bring it from add to full, a little confused about that. Ill check it again soon to verify.
Half quart from add to full lines is normal.
 
Joined
Jun 17, 2013
Messages
1,607
Location
USA, FLA
What kind / brand of vehicle do you have? Also did you make sure the car / truck was on level ground? I know people whom check fluid in the drive way and the driveway is Not a FLAT surface and then end up thinking that most the fluids are low. Also look in your owners manual how to check your ATF.. Some say to have in Nutral with car at IDLE and warmed up.. Other say to leave in park..... You never know till you look in your owners manual for the correct procedue... Also if you have a car made in USA then the Valvoline Max Life will be fine. However on Imports Im very picky. Good luck.
 
Top