Is this a failing thermostat?

Status
Not open for further replies.
Joined
Jan 11, 2007
Messages
935
Location
El Oeste
2008 Suburban with 5.3 GM motor in it. Just in the last few days it's been very slow to warm up and doesn't ever get to the 210-degree mark on the temperature gauge, where it normally runs. It's been running about 195 to 205. Any experience I've ever had with a car not coming up to temp was fixed by a new thermostat. But before I tear into it, I wanted to check here and see if anyone had any other ideas what is causing these symptoms. Also, I've used Stant thermostats before with good success. Any other suggestions or brands to stay away from, assuming it is a thermostat issue? Thanks a lot.
 
If it is running normally during warmup then I agree - thermostat is sticking in the open position.
 
Just curious, how easy can you see the difference between 205F (current normal) and 210F (previous normal) on the temp gauge?
 
Most newer vehicles run around 200 - 212F. Older will run anywhere between 195-200F. (There are exceptions) It's possible that the thermostat is starting to stick open and about to fail. I had this problem on my Santa Fe. It would be 195 all the time and then one fall it was 188F and shortly thereafter it failed open and wouldn't go past 100F.
 
I've used several brands with success. However, my rule of thumb is the harder a part is to replace, the more likely I will use an OEM part. However, it's a thermostat. OEM ones usually don't cost that much anyways.
 
You might be able to tell if it's getting stuck open by looking down the radiator cap right after you start the car from cold, there shouldn't be any coolant flow since the thermostat should be closed.
 
The PCM monitors thermostat performance almost every time you start your car cold. It checks to see that the coolant is reaching the target temp within a required amount of time. If not, P0128 sets. If you aren't getting a CEL, I wouldn't worry about it.
 
Can you hook a live data reading code reader up? I bought my truck with what I knew was a stuck open thermostat. No big deal. It went up halfway between the 100*F and the 210*F and stopped. I replaced it with a NAPA (US made part and only t stat locally with a lifetime warranty) and it went up to the 210*F and dropped down to just above the halfway mark. I was left scratching my head, but the heat felt hotter. Hooked my code reader up and she was at 192*F. The thermostat opens at 195*F.
 
Yeah I'd replace it. Just not with a Stant. My grandparent's Trailblazer had a stuck open thermostat. My mechanic replaced it with a Stant and it began to run hot. Replaced again and it still ran hot. Replaced with an OEM thermostat and it helped a lot. It had a bad fan clutch, but the Stant made it run warmer. This was because the opening of the Stant was smaller than the OEM thermostat, held side by side you could clearly see it, we also used a micrometer, I don't remember the measurements but it was somewhere around 15% smaller. OEM only for me from here on out.
 
When in question just change it. Less than 10 dollars and 15 minutes to change, it's not worth worrying over.They deteriorate over time. I would go with OEM but if you use a Stant, go with their "superstat" only.
 
Last edited:
Status
Not open for further replies.
Top