Corolla 4A transmission torque converter HELP!!

Status
Not open for further replies.
Joined
Aug 2, 2014
Messages
7
Location
New Zealand
Hi everyone, I am trying to put the torque converter onto our transmission for this engine but it doesnt want to seal, I've tried everything and looked at all the advice and forums online. The converter itself slides onto the first spline but doesnt want to move any further and is wobbly, I've tried rotating it while adding pressure, I've tried jiggling it, putting it horizontally and vertically, the thing just doesnt want to seal. Been at this for 6 hours now and its not fun frown Help would be appreciated by someone who has dealt with this similar problem, thanks
 
Last edited:
Joined
Jul 23, 2008
Messages
9,808
Location
New Jersey
not a trans guy here but is the new converter the exact match and could you call the converter company maybe they have some ideas
 

Gatman

Thread starter
Joined
Aug 2, 2014
Messages
7
Location
New Zealand
Its the same converter, the original block blew a big end so we bought a new block and transferred everything including the trans. All we did was remove the TC and now it just doesnt want to go back on
 
Joined
Mar 31, 2010
Messages
5,996
Location
Iowa
Why remove the converter? To install a new converter seal? I find that grabbing the pilot nub with your fingers and wiggling it a little while simultaneously spinning does the trick.
 

Gatman

Thread starter
Joined
Aug 2, 2014
Messages
7
Location
New Zealand
We removed the trans with the converter still on the block, thinking back that was a mistake and we should of detached the trans with the converter still on, as now we've tried everything to get it back on for the past 6 hours
 
Joined
Mar 3, 2014
Messages
242
Location
twin cities mn
If it's like the older Corollas, We used to pull out the center spline shaft and engage it in the torque converter then slide the shaft and the converter back in place together lifting slightly on the converter while turning. Once in a while we would lay the transmission on it's back and lower the converter in place. That way worked well too. Just put it in a pan first as it will leak a lot.
 
Joined
Aug 28, 2006
Messages
2,310
You may have broke or tweaked something when you removed the transmission that way. Look for damage.
Originally Posted By: Gatman
We removed the trans with the converter still on the block, thinking back that was a mistake and we should of detached the trans with the converter still on, as now we've tried everything to get it back on for the past 6 hours
 
Status
Not open for further replies.
Top