CarQuest Red filter with Magnet cut open

Messages
6,987
Location
Michigan
Here is another Carquest red filter cut open. Came off my daugthter's 2001 Ford Taurus. 7521 miles on this filter, magnet and Syntec oil. It appears the magnet caught a good amount of Iron particles. (3rd picture is after I swished some paint thinner around in the filter can to clean oil out of it.)
 
Last edited:
Messages
3,358
Location
Maryland
 Originally Posted By: StevieC
I have a filter-mag and have great results with it... I have similar pictures to those posted on their website. Works great! ;\)
Filtermag works the best in my opinion, anything else is not worth the money.
 

ZZman

Thread starter
Messages
6,987
Location
Michigan
I am sure it works better but most people do not want to pay that kind of money for one. Just like many people do not want to spend the money on Syn oil. StevieC....post those pics man!
 
Last edited:
Messages
25,045
Location
ON, Canada eh?
I will but I still have 14K KM to go on this fill of Amsoil. Also the filters in the Winter seem to catch more stuff than in the summer. I will post 'em here when I'm done with this fill! \:\!
 

ZZman

Thread starter
Messages
6,987
Location
Michigan
I would say that these particles looked very small and since filters do not filter all the way down to zero microns that many would not have been caught in the filter. You also have to remember that this was a first run on a car with over 120,000 miles on it. I am just glad they are not circulating whether by filter or magnet. **But if the filter was in bypass mode I would then assume that they would be missed.
 
Last edited:
Top