String trimmer head

Messages
2,280
Location
WNY
Friends, I have a 4 stroke Craftsman string trimmer and a bunch of attachments. One of which is a string trimmer. Re-loading it and using it doesn't make much sense to me, nor does it work well. Are there any universal trimmer heads that work well, feed line well and I could bolt onto this unit?

Thanks for all advice.
 
Messages
5,455
Location
Ohio
You might be able to obtain an OEM fixed length string spool assy for your Craftsman trimmer. Atleast it is quicker and easier putting in a 20 inch piece of heavier line than winding up two long lengths on your spool. I did that on my Craftsman trimmer and is much better than a bump head.
 

JRed

Site Donor 2021
Messages
2,311
Location
Virginia
I'd double check but I've put Husqvarna heads on Stihl and Echo trimmers.

I hate how some weed eaters reinvent the wheel when it comes to winding string into them. The default head on the cheaper Echo trimmers is ridiculous.
 
Messages
212
If it's a strait shaft you might be able to use an Echo Speed-Feed 400. I have one on my SRM225 and I love it (despite what the reviews say).

I agree on the speed feed - best head I have ever used.

Very easy to reload.
 
Messages
10,783
Location
Jupiter, Florida
If it's a strait shaft you might be able to use an Echo Speed-Feed 400. I have one on my SRM225 and I love it (despite what the reviews say).

I have a number of professional and non professional Echo products. I absolutely hate that trimmer head. It winds the string easily, that's for sure. But when it comes to playing out the string, if it gets short, it pulls it back in!!!! Absolutely infuriating.

I much prefer the old school Echo ones: p/n 9L3Z1A189A
 
Messages
212
I have a number of professional and non professional Echo products. I absolutely hate that trimmer head. It winds the string easily, that's for sure. But when it comes to playing out the string, if it gets short, it pulls it back in!!!! Absolutely infuriating.

I much prefer the old school Echo ones: p/n 9L3Z1A189A
I’ve never had an issue with the speed feed head. I used to have echo head that you had to manually feed
 
Top