Google Voice Not Recognize Mic

Sep 13, 2010
Central Texas
Has anyone had this problem w/Google Voice?:

Linuxmint 21.3, Firefox 126.0. Voice is allowed access to mic in Firefox settings. Under the headset icon, built-in stereo analog stereo is selected. Also tried monitor of built-in stereo analog stereo. I get no response speaking into mic. The Voice ... icon does not change to .I. icon when speaking which indicates google voice not accessing mic. Also get popup saying mic not recognized.

Other programs on my computer do respond to mic input. PulseAudio Volume Control also shows reaction to mic input.

Ran Firefox in troubleshoot mode with same results.

Google suggests installing Chrome (has many reports of the same problem)

Should I re install Firefox?
I booted up my old laptop which has same Linuxmint and Firefox version as my desktop computer. Voice worked on it. Recognized the mic. Firefox is installed on both computers as System Package. Went through both Firefox and Google voice settings and saw they were identical.
Never had any trouble w/Chrome (obviously the same company). I don't recall ever trying Firefox w/voice. There may be a way to disable & re enable mic drivers to see if that helps? It's a firefox or laptop issue. If you install chrome & voice works fine then it's safe to say it's a firefox issue or sorts. Have you tried uninstalling fox then reinstalling?
Grom the internet digging it's an issue with that version of mint but there is supposedly a workaround. From the Linux mint forum
"Found it. I went to Google Chat and then to the Help Center for instructions. There is a section on installing the stand alone app on Linux, I think."