Recent Topics
No TBN requirements for API but yes for ACEA PCMOs
by zeng
10/22/17 10:43 PM
Contests and sweepstakes.. no more.
by Reddy45
10/22/17 10:07 PM
Celebrity rides. Mostly good. Some BAD.
by 69GTX
10/22/17 09:21 PM
Napa 0W20 Interval
by oilstudent24
10/22/17 09:20 PM
STA-BIL anti-freeze ?
by Merkava_4
10/22/17 08:53 PM
When is the best time to go garbage picking?
by motor_oil_madman
10/22/17 08:20 PM
2005-6 Mercedes Benz E320 CDI opinions?
by Shaman
10/22/17 08:11 PM
Filter switch at WM
by Inspecktor
10/22/17 08:11 PM
Sears 'auto memories'?
by addyguy
10/22/17 07:11 PM
Are all house brand agm batteries the same?
by Chris142
10/22/17 07:11 PM
Brought home a free mower
by ford46guy
10/22/17 06:11 PM
Detailed another one of the Jeeps...
by HoosierJeeper
10/22/17 06:09 PM
Remote control battery covers
by buck91
10/22/17 05:49 PM
Vertical filters putting sludge right under bypass
by SOHCman
10/22/17 04:55 PM
Mystic 5W40 synthetic oil?
by BigdaddyG
10/22/17 04:30 PM
Absolute deliciousness
by car51
10/22/17 04:25 PM
Low pressure nozzles for pressure washer.
by motor_oil_madman
10/22/17 04:24 PM
Fran PH3614 7500 Km 3 months
by Run
10/22/17 04:04 PM
Fran Ultra XG8A 11250 Km 14 months
by Run
10/22/17 02:58 PM
Kansas Speedway...
by Warstud
10/22/17 02:13 PM
Newest Members
Two_Shoes, bigcmaple, Liebex, Techneek, bsmith6356
63176 Registered Users
Who's Online
51 registered (BigJakeChevy, Bandito440, 4WD, andyd, bbhero, BHopkins, 3 invisible), 1564 Guests and 14 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
63176 Members
66 Forums
272631 Topics
4526596 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4541232 - 10/12/17 01:58 PM 1998 k3500 7.4l wont start
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
I am having trouble starting my 1998 k3500 7.4l dually. One day it just shut down. Wound up being the coil. I replaced it and drover her for about 2 weeks. She shut off again. Thought maybe it was fuel pump. I replaced the fuel pump nothing. Replaced the coil again. Nothing. I replaced the camshaft postion sensor. I also replaced the crankshaft position sensor. I replaced the rotor and distribitor cap. I also replaced the ignition control module. Also the fuel filter. I am getting beautiful spark and plenty of fuel pressure. I am at my wits end with this truck and i cant think of anything else. Also i replaced all 8 spark plugs. I checked the timing by putting her at tdc. I also checked the maf sensor and map sensor. Please if anybody has any info please help...

Top
#4541238 - 10/12/17 02:02 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Nick1994 Online   content


Registered: 02/19/13
Posts: 8701
Loc: Phoenix, AZ
Spark to all cylinders?

Injectors pulsing?

Squirt some fuel down the throttle body and see if it tries to start.
_________________________
2015 Hyundai Sonata 2.4L 66k M1 AFE 0w30 & OEM
2000 Toyota Camry 2.2L 227k M1 AFE 0w30 & Wix
1996 Jeep Cherokee 4.0L 144k Napa 10w30 & Fram Ultra

Top
#4541254 - 10/12/17 02:19 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
Spark to all cylinders yes. And i tried carb cleaner and it doesnt start. How do i tell if they are pulsing

Top
#4541260 - 10/12/17 02:29 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Nick1994 Online   content


Registered: 02/19/13
Posts: 8701
Loc: Phoenix, AZ
I know on TBI engines there’s a bulb you can plug in to see if the injectors are getting power, not sure on the Vortec engines. Someone on here will probably know, might be able to just use a test light while cranking.
_________________________
2015 Hyundai Sonata 2.4L 66k M1 AFE 0w30 & OEM
2000 Toyota Camry 2.2L 227k M1 AFE 0w30 & Wix
1996 Jeep Cherokee 4.0L 144k Napa 10w30 & Fram Ultra

Top
#4541265 - 10/12/17 02:40 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
I forgot to mention the only code showing in the systmem is p1351 which is high voltage to icm but its a brand new oem icm i put on and nothing but the code keeps popping up everytime i clear it

Top
#4541284 - 10/12/17 03:20 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Rand Offline


Registered: 08/20/03
Posts: 11972
Loc: NE,Ohio
sounds like a possible wiring issue.

What fuel pressure do you have? does it hold fuel pressure for at least a few mins?

Sounds like maybe its time for it to go to someone with better tools and troubleshooting guide.
_________________________
2017 Jeep Cherokee Trailhawk V6

Top
#4541291 - 10/12/17 03:25 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
I took it to a mechanic shop and they are the ones who told me to replace the icm and spark plugs.

Top
#4541298 - 10/12/17 03:33 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
Rand Offline


Registered: 08/20/03
Posts: 11972
Loc: NE,Ohio
Originally Posted By: jubinjr
I took it to a mechanic shop and they are the ones who told me to replace the icm and spark plugs.


Well I hope you get your money back then because it didnt fix it.
_________________________
2017 Jeep Cherokee Trailhawk V6

Top
#4541307 - 10/12/17 03:43 PM Re: 1998 k3500 7.4l wont start [Re: Rand]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
Well i did the work myself. All they did was kind of diagnos it. Im just trying what else could be causing this issue. She sounds like she wants to fire but wont

Top
#4541354 - 10/12/17 04:30 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
mk378 Offline


Registered: 09/27/15
Posts: 950
Loc: USA
My friend has the same engine. The problem he had turned out to be a hole in the main spark wire from the coil to the distributor leaking sparks out. A test plug would fire outside the engine, but it was not enough spark to start it. If you can't get it to fire at all on starting fluid you should take a close look at the ignition parts, which as you know are very hard to see where they are way at the back of the engine.

Throwing codes related to the interface between the PCM and ICM could be a problem with the low voltage wiring, or even a bad PCM.


Edited by mk378 (10/12/17 04:32 PM)

Top
#4541422 - 10/12/17 06:04 PM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
kc8adu Offline


Registered: 08/02/05
Posts: 818
Loc: dayton oh
a bad coil wire can cause an insulation failure in the coil.
gets a gap burned in it that has to be jumped which causes overshoot.
you can get a spark with the plug out that is too weak under compression.
spark too weak or worse jumped timing.
have also seen rotor button arc through.

Top
#4541886 - 10/13/17 07:20 AM Re: 1998 k3500 7.4l wont start [Re: jubinjr]
jubinjr Offline


Registered: 10/11/17
Posts: 6
Loc: Florida,Ocala
How will i know if it isnt sparking inside the cylinder? And i have checked timing. Timing is correct

Top