Recent Topics
It's AMSOILŪ, not Amsoil
by Rat407
06/25/18 06:39 AM
VW Passat 2007
by madRiver
06/25/18 06:18 AM
Review: CVJ Remanufactured CV Axles
by The Critic
06/25/18 03:40 AM
Towing without 85w140?
by OilFilters
06/25/18 03:07 AM
2015 VW GTI autobahn oil questions
by Skyalbo
06/24/18 11:28 PM
Corrosion in the garage - salt or humidity?
by Kurtatron
06/24/18 11:13 PM
Darn dogs
by AZjeff
06/24/18 10:21 PM
New GC?
by Bullwinkle007
06/24/18 10:04 PM
The guy with the plexiglass head on you tube
by andyd
06/24/18 09:21 PM
'07 Pacifica Timing Belt Replacement success
by 92saturnsl2
06/24/18 09:10 PM
SAE 90 v 85/140
by Knuckle078
06/24/18 09:10 PM
Mobil 1 5W30-HM 5,011 mi, 1999 Ford Escort
by WA1DH
06/24/18 08:45 PM
Schaeffer's oil reviews on Amazon
by zfasts03
06/24/18 07:41 PM
Decent MP3 player
by Ed_T
06/24/18 07:08 PM
Letgo
by Donald
06/24/18 06:52 PM
Tire buying advice
by supton
06/24/18 06:23 PM
Two versions of M1 5w30 ESP now?
by Patman
06/24/18 06:21 PM
No older cars in New York State?
by Oldtom
06/24/18 06:19 PM
2009 Taurus strut mount noise
by terry274
06/24/18 04:38 PM
A3/B3 vs A3/B4, big difference or irrelevant?
by FordCapriDriver
06/24/18 03:36 PM
Newest Members
dhy808, ROD_Z, lozpxs, danthemanx07, FunktasticLucky
65319 Registered Users
Who's Online
65 registered (2015_PSD, 2009Edge, aquariuscsm, 97K15004WD, Astro14, 7 invisible), 1111 Guests and 29 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65319 Members
67 Forums
285956 Topics
4771953 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4392200 - 04/29/17 01:24 PM What Solvent to Remove High Temp RTV (Red)
The_Nuke Offline


Registered: 07/21/13
Posts: 295
Loc: D/FW Metroplex
Does anyone know of a good solvent I can use to remove cured High Temp RTV (Red)?

I used some of that stuff as an impromptu epoxy to mount an IAT sensor in an aftermarket CAI that didn't come with an IAT rubber grommet. Unfortunately, I now see that I oriented the sensor incorrectly and would like a Mulligan on my little jerry-rig. Successful removal of the sensor without effecting its operation (through incorrect solvent usage) is obviously going to be required before I can try it again, but I am not sure what I can use that isn't caustic or otherwise harmful to electronics and/or me.
_________________________
2012 Dodge Charger
- R/T with pursuit pkg.
- 5.7L + A5 + 2.65
"..it's got cop tires, cop shocks, cop suspension..."

Top
#4392207 - 04/29/17 01:43 PM Re: What Solvent to Remove High Temp RTV (Red) [Re: The_Nuke]
bdcardinal Offline


Registered: 06/03/05
Posts: 11014
Loc: Santa Barbara, CA
_________________________
2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.

Top
#4392526 - 04/29/17 08:42 PM Re: What Solvent to Remove High Temp RTV (Red) [Re: The_Nuke]
Johnny2Bad Offline


Registered: 05/20/13
Posts: 1810
Loc: Saskatchewan, Canada
RTV, unless specified for electronics, isn't ideal at the best of times. The acetic acid curing type is corrosive to current carrying metals. But with some parts it's OK because the electronic components are potted (embedded in an electronics-safe compound).
_________________________
'57 FL Straight 50 wt
'90 Miata 1.8L w/Rotrex Supercharger [Mobil1 0W-40]
'96 Ram 1500 [3.7L Mobil1 0W-20 / 1L 15W-50]
'01 PT Cruiser [Mobil1 0W-40]

Top
#4420715 - 06/02/17 09:42 AM Re: What Solvent to Remove High Temp RTV (Red) [Re: The_Nuke]
ironman_gq Offline


Registered: 04/30/14
Posts: 604
Loc: MN
elbow grease is the safest method. Cut as much off as you can and them peel and scrape the rest off. Red is pretty resistant to most solvents and anything that will dissolve it is going to damage the sensor.

Top