wifi wireless adaper disapering??

Status
Not open for further replies.
Joined
Sep 23, 2006
Messages
11,277
Location
Bad Axe, MI
ASUS laptop W7 Home premium x64 IE11, hard to explain bear with me.... Having an odd problem here, started outa the blue my wifi randomly.. stops working after a reboot or shutting it down for the night so I check on it in device manager and find its corrupted and missing. Doing a system restore brings it back then after that I have to do a network adapter trouble shoot scan to turn it back on and get it working. After all that it'll work for a few reboots then all of a sudden it's gone again and I have to do a system restore once again. I've tried to uninstall the driver and reboot but it fails to load. I attached a few screen shots maybe it'll help showing what I mean.. any ideas?? first pic all is well and working.. second pic is corrupted or missing..
 
Originally Posted By: daman
ASUS laptop W7 Home premium x64 IE11, hard to explain bear with me....
Is your laptop set to automatically install Windows updates? I had this same issue with a coworkers Asus laptop. The WiFi adapter would just disappear. I tried to reinstall the driver and Windows would say the current driver was the correct one. Tried to install a different driver and it said it wasn't signed properly. Do a system restore, all back to normal and everything is fine. Turned it off, let it sit overnight and check it, disappeared again. I took a look at the history and realized Windows had reinstalled the updates that I undid with the system restore. I disabled Windows updates, do another restore and shut it down. Check it the following day, all good. I'm not sure what update it was, as I gave it back, but I told him to install them one by one until he figured out the problem one and then block it. Hope this helps.
 
Thanks, right now I have it to "never check" disabled, I do it manually, so what do you advise then?
 
Set updates to security patches ONLY, you DO want security updates. Usually drivers are updated under the "Optional" updates. you can adjust that in settings. Then go to ASUS website and download the older driver and replace it. ...If it aint broke don't fix it.
 
Last edited:
Is it the half mini card? If so carefully take it out and then re seat it. I had a similar issue on a different brand laptop and this fixed it.
 
Originally Posted By: OVERKILL
I would try the latest driver for that card directly from Intel: Drivers here
Thanks overkill, what one do I need the 18.40.4 W7 64 in the upper left of the page?
 
Yes, the one from that link. Probably the 64 bit version (there are two links) assuming you are running 64-bit Windows 7.
 
Originally Posted By: OVERKILL
Yes, the one from that link. Probably the 64 bit version (there are two links) assuming you are running 64-bit Windows 7.
K thanks,, I ran the utility wizard it scanned and showed me the driver I needed, didn't see that at first. Updated the driver and did multiple restarts and so far its working, ill report back if not.
 
Originally Posted By: OVERKILL
Excellent. Yeah, the wizard sucks, I always just download the drivers directly and install them.
lol ok im wondering if the wizards version is the latest, Hmmm...
 
Originally Posted By: JustinH
Go to the Intel Driver Update site, and let it run a scan and update all the drivers at once, chipset, wifi whatever.
I'm not a big fan of that tool. I find it misses a lot of drivers.
 
Originally Posted By: JustinH
Yeah but so does the dell scan tool, also dell website sometimes misses some drivers for certain models. I use the intel one in a pinch.
Fair enough. Of the OEM ones, I think the HP Softpaq download manager is probably the best.
 
Sounds like a driver issue, but if system restore brought it back chances are something on your system is causing the issue. You may need to rebuild the machine with a Windows disc or a recovery cd from the manufacturer. Most pc's come with a recovery partition, just google the key to press while booting it up to restore it back to the day you got it.
 
Status
Not open for further replies.
Top