SuperPlug Results at 10k

Messages
116
Location
Southern California
Here is a picture of my SuperPlug after a 10k interval on Mobil 1. As you can see in the picture, the magnet did catch a small amount of material. When I cleaned it off it off, what came off looked like a very fine grey paste. It looks like it is doing its job.  -
 
Messages
742
Location
Lake Anna, VA
My LS1 Camaro has from the factory a magnetic drain plug and it does catch the gray paste of fine metallic particles your seeing. My first oil change at 500 miles and that thing was completely covered with gunk. Now with 6k on the clock it has less and less everytime I change the oil. On a side note I wonder if these magnetic plugs skew the oil anlaysis figures? Anyone care to comment?
 

Patman

Staff member
Messages
22,012
Location
Guelph, Ontario
I recently asked Terry Dyson if he felt that magnetic drain plugs skew the oil analysis results and in his professional opinion he does not believe that they do.
 
Messages
1,992
Location
Windsor,Ontario
I can't see the pic...but my SuperPlugs allways have a grey paste on them also...sure this probably would have been caught in the filter but my oil pump probably is happier not cranking that stuff up to the filter and my filter has better things to do with it's time if a few ferrous particles are left out of it's pleats..by the way they are a great company to deal with...I bought two plugs for my vehicles and one arrived with a bit of the chrome off the tip of one of them...I called and they sent me another..no question asked...I they said keep the other one to boot...I put it in my bud's new 03 Jeep Rubicon for a "Jeep Warming" present [Cheers!]
 
Messages
1,992
Location
Windsor,Ontario
quote:
Originally posted by Greaser: I can't see the pic...but my SuperPlugs allways have a grey paste on them also...sure this probably would have been caught in the filter but my oil pump probably is happier not cranking that stuff up to the filter and my filter has better things to do with it's time if a few ferrous particles are left out of it's pleats..by the way they are a great company to deal with...I bought two plugs for my vehicles and one arrived with a bit of the chrome off the tip of one of them...I called and they sent me another..no question asked...I they said keep the other one to boot...I put it in my bud's new 03 Jeep Rubicon for a "Jeep Warming" present [Cheers!]
I said...they said...I messed up here...getting tired and I was too slow to edit...sorry [Duh!]
 
Top