Post your latest oil change

Joined
Dec 19, 2019
Messages
2,663
Location
Muncie, Indiana
1622851802506.jpg

Mom's 2008 Odyssey w/ 3.5L non-VCM V6 engine 187577 miles, 3798mi and 9mo on oil, OLM was at 15%
Out: It started as Supertech 5W20HM, but the final composition is rather indeterminate as I've topped it up with whatever was open and convenient in the garage and I lost track of how much top up I put in probably over 5qts in the last 9 months, consisting of a mix of 5W20,5W30, and 10W30 Castrol GTX high mileage, 5W20 Pennzoil HM, probably some 5W40 Delo.
Off: Fram COR6607ACC Walmart jobber filter.
In: Castrol GTX High Mileage 20W50
On: Fram XG7317
Went with the thick stuff, both valve covers are leaking, maybe the oil pan is seeping, the main seal appears to be leaking around the transmission. The car is pretty much trashed, rusting, the tie rods seem shot again, I think it's eaten another set of engine mounts, needs suspension work, needs resealed, probably needs brakes, probably needs a valve adjustment, I'm surprised the serpentine belt tensioner pulley hasn't seized yet it's been making noise for the past year, this car is pretty much not worth dumping any more money in and I don't like working on it because the engine bay is so cramped that it's worse than working on a compact., I suspect this car will be sent off for scrap before it needs another oil change.
 
Joined
Mar 12, 2015
Messages
18,040
Location
In the shop
View attachment 59412
Mom's 2008 Odyssey w/ 3.5L non-VCM V6 engine 187577 miles, 3798mi and 9mo on oil, OLM was at 15%
Out: It started as Supertech 5W20HM, but the final composition is rather indeterminate as I've topped it up with whatever was open and convenient in the garage and I lost track of how much top up I put in probably over 5qts in the last 9 months, consisting of a mix of 5W20,5W30, and 10W30 Castrol GTX high mileage, 5W20 Pennzoil HM, probably some 5W40 Delo.
Off: Fram COR6607ACC Walmart jobber filter.
In: Castrol GTX High Mileage 20W50
On: Fram XG7317
Went with the thick stuff, both valve covers are leaking, maybe the oil pan is seeping, the main seal appears to be leaking around the transmission. The car is pretty much trashed, rusting, the tie rods seem shot again, I think it's eaten another set of engine mounts, needs suspension work, needs resealed, probably needs brakes, probably needs a valve adjustment, I'm surprised the serpentine belt tensioner pulley hasn't seized yet it's been making noise for the past year, this car is pretty much not worth dumping any more money in and I don't like working on it because the engine bay is so cramped that it's worse than working on a compact., I suspect this car will be sent off for scrap before it needs another oil change.
And I thought I was a “thickie” running SL M1 10w40 HM thru a below 0F winter 🤣🤣🤣
 
Joined
May 22, 2013
Messages
46
Location
MA
2008 Honda Accord ex-l v6 non vcm(6 speed manual)

out: Mobil 1 hm 5w20 and Fram ultra (2k oci (ran Amsoil Engine flush before i drained

in: Valvoline Maxlife red bottle 5w30 and Fram extra guard.

Trying to tackle some oil consumption issues on this car. Plan on running another short oci and monitoring oil consumption without driving the car hard. Was seeing consistent 1qt per 2000 miles oil consumption until I switched to Mobil 1. Now this oci has been closer to 1qt per 1000.
I Plan on running by epr/44k/Moa combo at the end of this short summer run. Also hoping this 5w30 holds up a little better in the sump.

may go back to Mobil 1 ep 5w30 after the bg flush because of rebates but here nothing but good things about semi sub Maxlife so giving it a shot
 
Joined
Sep 26, 2010
Messages
9,110
Location
COS
2020 Dodge Challenger SXT+ 3.6L V6

OCI = 800 miles

Out:

Mopar 0W-20 SN+

In:


Rotella Gas Truck 0W-20 SN+

-----------------------------------------------------------------------


2019 Jeep Wrangler Unlimited Rubicon 3.6L V6

OCI = 5,000 miles

Out:

RGT 0W-20 SN+

In:


Rotella Gas Truck 5W-30 SN+

-----------------------------------------------------------------------



2018 Mercedes C300 2.0T

OCI = 5,000 miles

Out:

Pennzoil Euro 0W-40 SN

In:


Pennzoil Euro 0W-40 SN
 
Joined
Jun 5, 2021
Messages
131
Location
Salt Belt
2011 Hyundai Sonata Hybrid 2.4 I4 Mileage: 87000

Out: Valvoline maxlife synthetic blend 5w20/ no brand yellow filter (yikes!)
In: Valvoline maxlife full synthetic 5w20/ OEM filter/ Fumoto oil drain value
OCI: 3500 Previous OCI is 5000.

This oil change is special because it is my first DIY oil change. Fed up with the high price and cheap oil/filter autoshop would put on my car.
IMG_4757.jpg
IMG_4764.jpg

I enjoy the fun and satisfaction of putting good new oil in my car and having peace in mind knowing things are done right. :D

The last place I went over torqued my drain plug and my washer is missing:rolleyes:. Have to spray some de-grease and using a socket wrench to get it off.
Before this oil change I always use synthetic blend. Despite getting better oil, my engine feels the same. Next time I will try those Extend Performance oil, see if that will make my car run better.
 
Last edited:
Joined
Jul 14, 2020
Messages
28
2020 Equinox 1.5t
Out: Royal Purple 0w20 & M1-113A

In : PP GF6 0w20 & Fram 12060 10k filter & MOs2

8500 miles on car , 4500 on oil, OLM 51%
I was going on a long trip and didn’t want to go over 5000 miles or go below 20% on olm. First leg of the trip I’m at 9800 miles and after resetting OLM it dropped to 86%.
 

4WD

Joined
Sep 21, 2010
Messages
18,249
Location
Texas
2011 Hyundai Sonata Hybrid 2.4 I4 Mileage: 87000

Out: Valvoline maxlife synthetic blend 5w20/ no brand yellow filter (yikes!)
In: Valvoline maxlife full synthetic 5w20/ OEM filter/ Fumoto oil drain value
OCI: 3500 Previous OCI is 5000.

This oil change is special because it is my first DIY oil change. Fed up with the high price and cheap oil/filter autoshop would put on my car.
View attachment 59564 View attachment 59566
I enjoy the fun and satisfaction of putting good new oil in my car and having peace in mind knowing things are done right. :D

The last place I went over torqued my drain plug and my washer is missing:rolleyes:. Have to spray some de-grease and using a socket wrench to get it off.
Before this oil change I always use synthetic blend. Despite getting better oil, my engine feels the same. Next time I will try those Extend Performance oil, see if that will make my car run better.

Excellent on most levels. However, should you admit to using an adjustable wrench on a drain bolt … this may require a Tribol Leader Review 👀
 
Joined
Feb 4, 2018
Messages
1,318
Location
Berks County/Pa.
2008 Acura TL in signature (122,269)

Out -- Frankenblend -- 1.5 quarts of PUP 5W20, .5 quarts of PPHM 0W20, 2 quarts QSHM 5W20 & half quart of Rislolne High Mileage Engine Treatment & ST9688

In -- 4.5 quarts of Pennzoil Ultra Platinum 5W20 and Fram Ultra
 
Joined
Jun 5, 2021
Messages
131
Location
Salt Belt
Excellent on most levels. However, should you admit to using an adjustable wrench on a drain bolt … this may require a Tribol Leader Review 👀
Yes... I'm guilty on that :p. I'm not sure what kind of torque wrench should I purchase. It's a M14-1.5 drain plug.
However to put the Fumoto drain valve on I had to use adjustable wrench. Despite it fits my vehicle, bolt part of the valve is slightly larger than M14 and my socket wrench no longer fits. I check my dip stick and parking lot floor everyday, make sure oil level is good and nothing leaking from my filter or drain plug. So far no leak detected. I probably will go under my vehicle once again for a through check.

- Oh well, "The council will decide my fate" XD
 
Last edited:
Joined
Dec 19, 2019
Messages
2,663
Location
Muncie, Indiana
And I thought I was a “thickie” running SL M1 10w40 HM thru a below 0F winter 🤣🤣🤣
I probably wouldn't run this during the winter, and if I did, I'd be looking for a larger filter than the stock lawn mower filter, it's fine for 0W20 or 5W20, but I don't like the idea of having that tiny little filter if you're running 15w40 or 20w50 during the cold time of year, I'd probably use the XG3593A or that ridiculous Baldwin filter I found one time, I think it was the size of a ph3600 but it had the metric thread and gasket used on most Honda/Nissan/Kyundai vehicles.
 

4WD

Joined
Sep 21, 2010
Messages
18,249
Location
Texas
Yes... I'm guilty on that :p. I'm not sure what kind of torque wrench should I purchase. It's a M14-1.5 drain plug.
However to put the Fumoto drain valve on I had to use adjustable wrench. Despite it fits my vehicle, bolt part of the valve is slightly larger than M14 and my socket wrench no longer fits. I check my dip stick and parking lot floor everyday, make sure oil level is good and nothing leaking from my filter or drain plug. So far no leak detected. I probably will go under my vehicle once again for a through check.

- Oh well, "The council will decide my fate" XD
I think your torch is safe, LoL … I put a Fumoto on the 5.3L and that’s the easiest thing to grab one with. Really like the ball valve more than expected … got rid of lots of splash and can reach it without ramps … even do a quart swap based on OLM
 
Joined
Sep 10, 2005
Messages
4,995
Location
Massachusetts
My daughter finally came up from CT. Was going to change it last week, but change of plans. Now it's 93 outside.....kids.

2015 Chrysler 200 84,599 miles

Out: 0W20/5W20 Idemitsu/Franken 20's
In: 2.5 qts PP10W30 and 2.5qts PP5W20
8,400 miles on the interval (yep - OLM hit 0% last week).
 
Top