Post your latest oil change

Joined
Mar 1, 2010
Messages
708
Location
Finland
1995 Chevrolet Silverado K2500 6.5d out: Neste Turbo LXE 15W-40 (short 400 km or so oil change after two years hibernation) in : Neste Turbo LXE 15W-40
 
Joined
Mar 4, 2013
Messages
1,019
Location
Va
2010 Subaru Forester 60895 miles. Castrol 0w-30 with Subaru filter in today, replacing PYB with wix filter after 3100 miles.
 
Last edited:
Joined
Aug 30, 2004
Messages
28,730
Location
CA
2011 Prius, 59k Out: Mobil 1 AFE 0w-20, OE Filter 9,740 miles In: Pennzoil Platinum 0w-20, OE Filter
 
Joined
Sep 21, 2011
Messages
180
Location
Mn
BIL's 2010 Toyota Corolla 1.8l Out: Quick-lube 5w-20 Conventional -8k Miles on oil Oil actually looked pretty good. I've seen worse come out of cars with fewer miles IN: Pennzoil Platinum 0w-20, Napa Gold Filter
 
Joined
Mar 24, 2013
Messages
46
Location
Pekin, IL
'87 LSC: Out = uknown oil + unknown filter In = Castrol GTX 10w40 + FL-1A Dirty after less than 1 hour of run time due to previous owner's neglect so I changed it again. In = Castrol GTX 10w40 = FL-1A '01 Suburban: Out = Castrol GTX 5w30 + Wix filter In = same '97 Impreza: Out = Castrol GTX 10w40 + Wix filter In = same After a LOT of reading on BITOG I'll be switching to Pennzoil HM.
 
Joined
Jul 21, 2012
Messages
1,352
Location
Ohio
2004 Honda Accord V6 Out: Pennzoil Ultra 5w-20 with Bosch DistancePlus In: CATERHAM 2qt TGMO 0w-20 + 2.5qt M1 0w-40 with Purolator PureONE UOA sent.
 

ECS

Joined
Feb 8, 2013
Messages
13
Location
Colorado
'08 Mercedez C300 - M1 0w40 '09 Jetta TDI - Pennzoil Ultra Euro L 0w30 '12 Honda Civic - Mazda 0w20 SN '13 Passat TDI - still on FF
 
Joined
Nov 11, 2010
Messages
9,774
Location
Saskatoon canada
88 5.0 fox body mustang. First oil change since I took possession of the car. Unknown oil out. The oil itself felt not like oil at all,as if there wasn't any viscosity left. And black like road tar. So I drained it but left the filter,put in 4 litres of co-op d-mo 0w-40 hdeo and a litre of mmo. Ran it for a tank of fuel,drained it,again very black and refilled with a Walmart jug of pyb 5w-30 and half a litre of mmo. Going to run this for a few tanks,just to see how quickly the oil turns to mud again. Once this flush out is finished I think I'm going to use the 5 litre jug of liqui-moly 10w-40 with mos2 already added,and see if fuel consumption is affected. I love my 2000gt but there is nothing like the sound of a pushrod 5.0. It's like music to my ears.
 
Joined
Jan 4, 2010
Messages
1,250
Location
Oklahoma
Vehicle: 1999 Lexus GS 400 Out: Mobil 0W-20, in for 12 months and one week and 7864 miles. In: 4 quarts of Mobil 0W-20 and 1 quart of Mobil 0W-40.
 
Joined
Mar 21, 2013
Messages
20
Location
WI
Daughter's 1998 Saturn SL2 w/111,000 miles Out: Valvoline NextGen Maxlife 5w-30 & Purolator PureOne - Oil FAR IN: Valvoline NextGen 5w-30 & Purolator Classic - Oil FAR
 
Joined
Jun 28, 2003
Messages
6,652
Location
Illinois
2008 Hyundai Accent 3.5 qts M1 0w20 and Hyundai filter, 7k miles 2010 Hyundai Genesis Coupe 2LT 5.5 qts M1 0w40 and AC Delco filter, 5k miles Same oil out as in on both.
 
Joined
Apr 1, 2010
Messages
1,084
Location
Ontario , Canada
2005 Ford Five Hundred Drained M1 0W20 AFE and M1 extended life filter with 10K km on it . Oil still looked pretty good , not very dark . Filled with Royal Purple 5W20 and a M1 extended life filter just for the heck of it. From what I read in another thread my car is doomed to sludging up on the RP frown
 
Last edited:
Top