No filters except Wix,Napa Gold,Purelator

Joined
May 12, 2008
Messages
6,318
Location
Canton, GA
For some reason my jerky Lexus/Toyota 1MZ-FE motor has start up rattle on any filter except Wix,Napa Gold,or Purelator. I have a nice Mobil-1 filter on it now,blew in it and all that jazz,and the [censored] thing rattles on start up!! It`s really starting to [censored] me off!! now I have to crawl under their again,take down the plastic splash shield etc.etc. The wife is like: "your always doing something under that friggin car"
 
Last edited:
Joined
Mar 27, 2009
Messages
110
Location
The Capital
The same start up rattle used to occur since changing the filter from Mann to mobil1 filter on my volvo I6, now it does not after 1000 miles.
 

lexus114

Thread starter
Joined
May 12, 2008
Messages
6,318
Location
Canton, GA
 Originally Posted By: daves87rs
It's telling you it wants the good stuff...
Yeah,I suppose your right.
 
Joined
Aug 21, 2008
Messages
25,051
Location
ON, Canada eh?
Try an Amsoil EAO filter as a test and see if you have the same problem... If you don't then just run that filter for 15K miles. It's a very robust filter with great flow and will save you having to remove the plastic plate under the car so often. ;\) My Santa Fe is one of those picky engines and it likes certain filter and certian oils or else it gets Biatchy.
 
Joined
Aug 21, 2008
Messages
25,051
Location
ON, Canada eh?
I have had the same headaches with my truck. Then I though I had it solved and the winter came and it came back... Only filters I could make my engine quiet with in the summer/winter were Wix, or Amsoil EAO. I stuck with the EAO because it's extremely well built inside and will last for a long time. Saving me the trouble of changing it out as frequently and leaving my engine quiet! ;\) I too have a skid plate under my truck, and while Hyundai was nice enough to give me an access door to the filter, it doesn't leave much room for your hand and oil drips all over the MF thing and makes a mess so I enjoy not changing the filter as often. I feel your pain!
 
Joined
Jan 19, 2009
Messages
267
Location
USA
The original Toyota filters are just as cheap, might try that. Or a Denso to get the same filter with red silicone adbv. Personally I think the black nitrile valves work just fine for normal intervals. I thought on that engine the filter is changed from above.
 

lexus114

Thread starter
Joined
May 12, 2008
Messages
6,318
Location
Canton, GA
 Originally Posted By: Newtonville
The original Toyota filters are just as cheap, might try that. Or a Denso to get the same filter with red silicone adbv. Personally I think the black nitrile valves work just fine for normal intervals. I thought on that engine the filter is changed from above.
I thought on that engine the filter is changed from above. Yeah,I wish it was! I may look into a filter re-location kit for this.
 
Joined
Jan 22, 2003
Messages
1,676
Location
Waldorf, Maryland
Years ago I switched my Corvette from GM's premium filter (UPF-44) to WIX or NAPA Gold (same filter). I did this because a lot of corvette owners were complaining that they and the Mobil 1 filters, filter too good, at the expense of oil flow. My cold start oil pressure increased 10-15 psi with WIX. Since the Corvette oil pressure sensor is AFTER the oil filter, more pressure equals more flow. I now use WIX on all my cars.
 

lexus114

Thread starter
Joined
May 12, 2008
Messages
6,318
Location
Canton, GA
 Originally Posted By: Corvette Owner
Years ago I switched my Corvette from GM's premium filter (UPF-44) to WIX or NAPA Gold (same filter). I did this because a lot of corvette owners were complaining that they and the Mobil 1 filters, filter too good, at the expense of oil flow. My cold start oil pressure increased 10-15 psi with WIX. Since the Corvette oil pressure sensor is AFTER the oil filter, more pressure equals more flow. I now use WIX on all my cars.
Good information CO
 
Top