New axle new problem

Messages
3,372
Location
Kansas, USA
The previous drivers side axle in the Aspire clicked on corners so I replaced it today. It's always pulled hard to the right on certain roads and when it pulls hard would make a wobble sound. The alignment is close enough it shouldn't pull that hard. I replaced the bushings today that usually makes it do that on the Festiva/Aspires and it still does it. It has been hit on the passenger side front and the cross beam is bent (see below). The problem now is it sounds awful. I guess it's pulling on the new boot. I'm going to measure the axle tomorrow but I'm pretty sure it's the same. Thoughts? I hate to say I think this car is now parts material. I can salvage alot of parts and put on the Festiva still hate to do it.. rides pretty good. Has alot of electrical problems and doesn't run right half of the time and don't think it gets good mileage but never been able to measure due to not be able to fill the tank, hose is leaking.
 

Eric Smith

Thread starter
Messages
3,372
Location
Kansas, USA
Well unfortunately I put a hole in the boot and I got it from Rockauto.. so no. The Aspire rode better on my commute but the Festiva is nicer and probably ride better with the Aspire suspension. Probably get almost 40mpg with the 97 Aspire auto and down move with the different gear ratio and weight.
 
Messages
1,712
Location
VA
Originally Posted By: Eric Smith
rides pretty good. Has alot of electrical problems and doesn't run right half of the time and don't think it gets good mileage but never been able to measure due to not be able to fill the tank, hose is leaking.
That would make some great Craigslist copy. grin Are you talking about the Aspire you want to keep driving, or the Festiva?
 

Eric Smith

Thread starter
Messages
3,372
Location
Kansas, USA
LOL It would wouldn't it. The Festiva I would keep. It's body is perfect except the paint. Giving myself a few days to figure out what I want to do.
 

Eric Smith

Thread starter
Messages
3,372
Location
Kansas, USA
Well **** turned out I forgot to tighten the drivers side lug nuts. I'm officially a idiot.. actually I past that a few years ago not sure what the next level would be.
 

Eric Smith

Thread starter
Messages
3,372
Location
Kansas, USA
It won't but truthfully I've been driving it for almost a year and the only symptom was the pulling. I haven't been able to drive it since tightening the lug nuts to see how it drives. If it still drives the same I should be able to get a little more life out of it. That almost needs a straightened out more.. I did straighten it some since that pic.. and a piece of metal welded on there.
 
Messages
36,515
Location
ME
It's probably messing up your camber, usual fix is to elongate a strut mounting hole. What do you have to lose? Get a bubble laser level and straighten things out.
 
Top