Need mechanical help with a 3.4 Venture motor ASAP

Messages
3
Location
USA
Hi I have a 2004 Chevy Venture 3.4 with 167,000 miles on it. I had a leaking intake gasket and after fixing and completing it I broke the 8mm rocker bolt on one of the valves. I then did a Heli-Coil thread repair on that valve and put everything back together. After I started the van up it made a valve noise so I decide to change the heads (used heads) on both sides with the better 10mm bolt head (which don't break) and a brand new head gasket. After 4 days it started mixing oil and radiator fluid on the top of the engine and not the lower half and it’s also losing anti-freeze and its burning 2 quarts of oil every 4 days. It's also overheating due to coolant and oil loss at the same time. It’s not smoking from the tail pipe, it’s not leaking anywhere and the head gasket is brand new. What could be the issue?
 

Carz

Thread starter
Messages
3
Location
USA
This answer could be correct but why is it burning oil and coolant? No leaks, or smoking just gone.
 
Messages
2,287
Location
Canada
Originally Posted By: Carz
No leaks, or smoking just gone.
The cat will burn all that up, so you won't see smoke until it's REALLY bad. If there are no leaks on the underside of the engine or on the driveway, there's only one place it could be going: the combustion chamber.
 
Messages
3,701
Location
Northern Ontario, Canada
My Venture lasted to 180,000 miles, put on rebuilt heads (originals cracked at the middle valves), lasted another 14 months, started eating coolant and I sold it to a mechanic at about 210,000 miles. Too bad as the van was perfect otherwise, tranny was good, body etc.
 
Last edited:
Messages
7,430
Location
beaver land EH?
well, did you check the following? (1) check both engine block deck and head mating surface for "straightness"? (2) did you check/clean the head to block mating surface carefully, with solvent? (3) did you follow the factory head bolt torquing sequence and do them in stages? (4) did you re-use head bolts? or bought new ones? (5) was your engine (lower part) burning oil before? Q.
 
Messages
5,651
Location
Iowa
Dunno, sounds like a botched intake gasket. Oil and antifreeze mixing, burning lots of oil? First guess would be the intake gasket. Bum head gasket install doesn't explain the oil burning on this engine.
 
Messages
10,060
Location
Central Washington
Originally Posted By: The_Eric
Dunno, sounds like a botched intake gasket. Oil and antifreeze mixing, burning lots of oil? First guess would be the intake gasket. Bum head gasket install doesn't explain the oil burning on this engine.
Agree. Just to clarify, is coolant getting into the oil sump? Oil into the radiator? Or just on top of the engine they are leaking out and mixing?
 

Carz

Thread starter
Messages
3
Location
USA
It's mixing in the radiator and the top of the engine under the valve cover. When I pull the dipstick for the engine oil, it's clean. Before I did all this work the engine never burned oil. The only problem I had was the intake gasket was leaking, then I had to change the heads due to those [censored] 8MM bolt heads that brake easy.
 
Messages
5,676
Location
Fort Worth, Texas
Originally Posted By: Carz
It's mixing in the radiator and the top of the engine under the valve cover. When I pull the dipstick for the engine oil, it's clean. Before I did all this work the engine never burned oil. The only problem I had was the intake gasket was leaking, then I had to change the heads due to those [censored] 8MM bolt heads that brake easy.
Leaking Oil Cooler? Not sure if a Venture has a Oil Cooler?
 
Top