Motorcraft FL-820S, ~9000 miles

Joined
Jan 10, 2008
Messages
1,178
Location
TX
This filter came off my Expedition. I have about 107K miles on it. Always run M1 of some kind, currently M1 5W-20 Truck & SUV. I normally change right at 7500 miles, but we took a road trip this month and I pushed about 1500 miles past that. The ADBV still worked great. Despite having left it draining for days, it was full of oil when I cracked it open: [Linked Image] Filter media seemed fine to me: [Linked Image] [Linked Image] [Linked Image] Overall, seemed fine, as usual: [Linked Image] [Linked Image] I put another FL-820S on and another seven quarts of M1 5W-20 T&S in it and will drive it another 7500 miles!
 
Joined
Dec 4, 2004
Messages
13,225
Location
1/2 hr N.E. of Detroit
I have the exact same plastic oil drain-pan and only used it three times in 10 years - out of thirty or-so opportunities. I'll give it another-Go next month. But it's narrow depth belly would never be a friend of our Hyundai 2.4, who's used engine oil lets-loose like a freight train, once the oil drain plug is removed. I've never owned another vehicle that removes it's used oil so quickly - with so much thrust. Your plastic pan would splash drained oil al over my driveway under that Hyundai 2.4, even if I was lucky enough to center your plastic pan dead center to first harrowing squirt. I gotta' have a real deep plastic pan, or else a 4x4 sheet of cover, to save my still-white new driveway from a multitude of black spots. I wanted to discuss your UOA. But most UOAs are so boring. Nothing to talk about .... even at almost 8K. Congrats on a successful run with this oil. Your Expedition engine is progressing real well. Used oil looks clean and that Motorcraft didn't come with any big, negative surprises. There's one questionable spot in that first photo..... but many filters show the strongest area of flow - plus bent, slight separation of media, in a small spot of the circular filter. Keep rollin' in a positive manner.
 
Last edited:
Joined
Oct 9, 2004
Messages
12,541
Location
Cincinnati, OH, USA
Looks good-for a 5W20 in Texas-but I would bet a winter run, up here in the colder North, would have had different results. The glued seam is also far superior to the metal crimped ones, the glued seam can flex under pressure.
 
Joined
Jun 22, 2015
Messages
1,351
Location
montreal ,canada
Originally Posted by Triple_Se7en
I have the exact same plastic oil drain-pan and only used it three times in 10 years - out of thirty or-so opportunities. I'll give it another-Go next month. But it's narrow depth belly would never be a friend of our Hyundai 2.4, who's used engine oil lets-loose like a freight train, once the oil drain plug is removed. I've never owned another vehicle that removes it's used oil so quickly - with so much thrust. Your plastic pan would splash drained oil al over my driveway under that Hyundai 2.4, even if I was lucky enough to center your plastic pan dead center to first harrowing squirt. I gotta' have a real deep plastic pan, or else a 4x4 sheet of cover, to save my still-white new driveway from a multitude of black spots. I wanted to discuss your UOA. But most UOAs are so boring. Nothing to talk about .... even at almost 8K. Congrats on a successful run with this oil. Your Expedition engine is progressing real well. Used oil looks clean and that Motorcraft didn't come with any big, negative surprises. There's one questionable spot in that first photo..... but many filters show the strongest area of flow - plus bent, slight separation of media, in a small spot of the circular filter. Keep rollin' in a positive manner.
I didn't see any mention of a UOA nor a link to one. Also the OCI was 9k not 8.
 
Joined
Dec 31, 2016
Messages
10,095
Location
Waco, TX
Originally Posted by Triple_Se7en
I have the exact same plastic oil drain-pan .... But it's narrow depth belly would never be a friend of our Hyundai 2.4, who's used engine oil lets-loose like a freight train, once the oil drain plug is removed..... even if I was lucky enough to center your plastic pan dead center to first harrowing squirt.
It works just fine on my Kia 2.4L GDI. ... Just take the white cap off the pan spout, so it can vent fast enough!
Originally Posted by Triple_Se7en
I wanted to discuss your UOA. But most UOAs are so boring.
I do not see where he posted a UOA.
 
Joined
Mar 20, 2015
Messages
10,432
Location
Virginia
Originally Posted by bullwinkle
Looks good-for a 5W20 in Texas-but I would bet a winter run, up here in the colder North, would have had different results. The glued seam is also far superior to the metal crimped ones, the glued seam can flex under pressure.
I'd bet money you would be totally right about this. This filter did actually survive for a long run. Amazing just how great the Motorcraft fl 400s and 500s always look in comparison to the 820s.
 

ZeeOSix

$100 site donor 2022
Joined
Jul 22, 2010
Messages
33,547
Location
PNW
Originally Posted by bbhero
Amazing just how great the Motorcraft fl 400s and 500s always look in comparison to the 820s.
Definitely ... I have no problem running the FL500S on a Coyote.
 

BlueOvalFitter

Site Donor 2022
Joined
Feb 28, 2003
Messages
11,620
Location
Cajun Country, La.
Originally Posted by ZeeOSix
Originally Posted by bbhero
Amazing just how great the Motorcraft fl 400s and 500s always look in comparison to the 820s.
Definitely ... I have no problem running the FL500S on a Coyote.
Z06, do you own a Coyote now? Moving up the ladder, huh?
 
Top