Mobil 1 used filter pics?

Joined
Feb 14, 2005
Messages
652
Location
RHODE ISLAND
I've seen a lot of dissected filters on this site (thanks to all who took the time to post them) but I can't recall ever seeing a used Mobil 1 dissection photo--I'd really like to see a Mobil 1 that has gone the distance, say 15,000-20,000 miles or so if anyone has one or will have one in the near future. I'm considering using a Mobil 1 for a 12 month/18,000 mile interval but would like to know if anyone else has done this and what the filter looked like in the end. Thanks.
 
Joined
Sep 28, 2002
Messages
39,802
Location
Pottstown, PA
I didn't do the BITOG full MONTY with M1 ..but.. I had an EaO and M1 side by side in a tear down. I'd have to find the thread to get my story straight on the media, but the M1 was used for 1 year/9500 miles w/RTS ..the EaO something like 15k or so with Bruce's oils (0w-10). They were similar in construction. The difference being that the EaO had a modular bypass valve mechanism, while it appeared that the Champ Labs M1 had one that was integrated. The EaO has mesh reinforced media, while I can't confirm this for the M1. The black stuff inside the M1 can is VSOT that sank out of suspension in the filter. I'm still reading moly trace (to the tune of 100-200ppm) over 15-20k later. The medias here are EaO (looked at the notes). The lighter media has been sprayed down with break clean, iirc. I'm not sure what I was looking for.
 
Last edited:
Joined
Feb 23, 2007
Messages
8,313
Location
Grand Rapids, MI
It's weird how at the bottom of the page if you look at "related photos" some of my pics are on there! Like the one of me holding my spark plug wires!
 
Top