Getting a shop to fix my car

Joined
Nov 20, 2006
Messages
28,948
Location
MA, Mittelfranken.de
Thanks. The head didn’t need to be resurfaced, but it has been removed multiple times now.

I went to the shop in person today, talked to the owner who is the person I’ve always dealt with through the years.

He was very gracious, he feels bad, he said that he has had issues and has had to step away from it a few times in frustration. And he’s busy in a big shop with one helper. I get it, the job is now costing him money. He recognizes that I brought a perfectly running car with a seeping (inboard to the coolant) HG, and now it’s a severely misfiring engine.

He says it shakes violently at idle, and says it’s #2 cylinder. The oval bores from bent rods were supposedly #1 or #6.

He said he took the head off a second time because of misfire. He drove it, and it is smooth and strong on the highway, but shakes at idle. His suspicion was a leaking valve, and he said that when he sent the head back to the machine shop, they found a slight leak on one of the valves (?). The seats were replaced the first time. So apparently that is on them. But after
Putting it back on, it still misfires on #2.

He said he has swapped injectors, and loosened each one, the one that doesn’t change for the worse when the fuel line is loosened is #2.

I asked if it could be fuel related, or perhaps timing related from when the chain came off. He didn’t think so. I’m not so sure I’m convinced. He thinks it maybe in the piston, though he isn’t sure how/why, and acknowledges that it wasn’t this way when I brought the car there (and i think this wasn’t an issue the first time the head went back on, when there was oil leaking).

The plan is that he’s going to do a leak down test this week hopefully, and get back to me by Friday. I might go back down on Friday PM when done with work…

If the leak down test shows cyl #2 is losing compression, that would indicate a ring that got damaged or a cylinder that got scored, right? If it is tight, then it has to be fuel… right? My money is on a fuel related issue. Bad delivery valve? Bad prime? Damaged injector somehow?

You need to look at the valve and injection pump timing. This guy explains it pretty good. You can do this job with a mirror once the timing plug is out on the pump.
Edit: Another thing I just thought of back from the old 200 and 240 times were make sure he didn't get the injector tubes mixed up.

 

JHZR2

Staff member
Thread starter
Joined
Dec 14, 2002
Messages
48,978
Location
New Jersey
You need to look at the valve and injection pump timing. This guy explains it pretty good. You can do this job with a mirror once the timing plug is out on the pump.
Edit: Another thing I just thought of back from the old 200 and 240 times were make sure he didn't get the injector tubes mixed up.


Thanks. Yeah I have to think that it deserves a bit more attention for the fuel system.

That said if it’s contained to only one cylinder, how does that make sense?

If I drove it, assuming it’s truly running smooth on the highway and only rough at idle, do you think I risk any damage?
 
Joined
Nov 20, 2006
Messages
28,948
Location
MA, Mittelfranken.de
Thanks. Yeah I have to think that it deserves a bit more attention for the fuel system.

That said if it’s contained to only one cylinder, how does that make sense?

If I drove it, assuming it’s truly running smooth on the highway and only rough at idle, do you think I risk any damage?
Try it, I doubt it is running 100% at higher rpm, I would bet the higher rpm is just masking the problem.
 
Joined
Jul 11, 2015
Messages
7,723
Location
New England
Good luck I hope best outcome. Most mainstream mechanics don’t touch old stuff because of all the challenges and surprises lurking when they simply touch vehicle.
 

JHZR2

Staff member
Thread starter
Joined
Dec 14, 2002
Messages
48,978
Location
New Jersey
I stopped by again and he has pulled the car in to do compression and leak down. We noticed that injector #2 is wet, so he is going to look at fuel more too. Said
the engine started well for having a nearly dead battery.

I got to see the original HG. Hard to see where the oil was crossing over from.

01B36901-6B2B-47B8-B5F4-2984507510F8.jpeg
A10AB11E-D345-4B2A-A418-A339C248EB89.jpeg
5ABBEF46-D6E2-4C47-A746-A48D97FF8EBE.jpeg
 

JHZR2

Staff member
Thread starter
Joined
Dec 14, 2002
Messages
48,978
Location
New Jersey
I wouldn't think timing as valves bend if not right. I will more than likely be injectors since it has old diesel in it.
Ive run much older diesel and these engines fire up and run smooth…. But I do agree fuel system, knock on wood,
 
Top