Found new toy I can use GC in...

Status
Not open for further replies.
Joined
Oct 30, 2002
Messages
42,343
Location
Great Lakes
Picked up this little guy the other day... haven't had a chance to use it yet. Will fill it with GC once I dump the factory oil.

P1040342.jpg


P1040343.jpg


P1040340c.jpg


P1040347.jpg
 
Originally Posted By: simple_gifts
I recommend dumping the factory fill before 1200 miles....

I'm guessing it'll be much less than that actually. The manual says 5 hours. Even if I run with it that entire time, I won't be able to do more than about 30 miles.
grin2.gif
 
Originally Posted By: LT4 Vette
Nice Toro, but I like the BMW in the background a little more.
wink.gif


Thanks. But at least the Toro doesn't leak oil and coolant all over the place...
 
That last pic is tough! Hey glad it's got the Briggs engine too. I hate the Hondas.
 
QP, Nice mower! Us BITOG'ers think alike as I did the same thing! I purchased a new Toro at the end of '07, ran the FF about 5x dumped it for GC in early '08, changed it again at the end of '08.

I wonder how long the mower will last with only running GC in it? My son will give it to his kids! LOL

cheers3.gif
 
Pete,

I have a couple UOAs on my Toro mower w/ B&S engine, one with AMSOIL.

I would recommend changing the oil after a total of 3 hours. It is very grey even then.
 
Originally Posted By: benjamming
Pete,

I have a couple UOAs on my Toro mower w/ B&S engine, one with AMSOIL.

Found them, thanks. Sucks that your engine died so quickly. How did that story end? You got a new engine or a new mower?

Quote:

I would recommend changing the oil after a total of 3 hours. It is very grey even then.

Well, I guess it is to be expected from an engine without a filter.
 
Sort of off topic but what's the logic in rating mowers by their torque these days? Do they tell you at what rpm it makes 6.75 ft lbs? It would make the old 2 strokes look bad as their hp was up higher but they aren't sold anymore I think?
Johnny
I have a 25 year old lawn boy, not the commercial grade one but it seems built pretty well! Has yours needed the engine opened up yet? Mine hasn't so far.
Ian
 
Status
Not open for further replies.
Back
Top