Chrysler PT Cruiser cental locking gremlins

Joined
Nov 21, 2021
Messages
11
Location
New Zealand
Hi all,

In NZ.
Have an '05 PT Cruiser that has haunted central locking.
90% of the time, if I unlock the either of the front doors, even just using the key, the tailgate/rear hatch unlocks, and turns the interior lights on, and if I don't notice, I can end up with a dead battery.
I get a warning on the dash, plus a ping every time I pull away from being stopped.
It will also do it randomly while I'm driving, and there appears to be no consistent reason for triggering this sort of event.
I removed the battery from the remote, in case it was sending signals to the car of it's own accord, but no change.
It's a chore, as I have to open and then close the hatch, and even then, I can start to walk away, and I hear a clunk, and it's unlatched itself again. Doesn't matter if the front doors have been locked again - it still does it whenever it gets the urge. It will often do this multiple times.
I was hoping to disconnect the electric actuating mechanism from the latch, and just go key-only, but no. It seems that Daimler-Chrysler, in their infinite wisdom, appear to have made this particular model variant with all-electric actuators, which is problematic - I dunno how you're supposed to get into it in the event of TOTAL battery failure.
Anothe thing I've noticed, too, is that I occasionly get an ABS warning light and a traction control light coming on, and while the car is still driveable, it would not pass a roadworthiness test with those warning lights on. Fortunately, it is legal until June 2022, but I kinda want to sell it, and I don't feel good about that with these issues going on. No Check Engine light, though.
I've been told that these vehicles can have issues with body earth points, but there are a heap of them, and I only have one functioning arm - surgery this Thursday! - and I can't currently use tools or bend at the moment. I have a factory service manual, but it doesn't seem to cover this freakish behaviour, either. There is a large amount of interior trim to remove to gain access the the interior of the rear hatch - like a lot.
The local Chrysler-Jeep workshop said they have NO idea what the issue might be, and given that they want $3K to replace the cambelt, I'm not keen to have them spending hours trying to diagnose the electricals. At least they were honest enough to say that they were clueless in this instance. The auto electrician around the corner won't touch it, and neither will the locksmiths - the sent me to the C-J workshop...
Any ideas would be greatly appreciated, apart from the obvious ones such as dropping a 16-ton weight on it, or finding a box of matches, etc.

Cheers, people.
 
Joined
Mar 7, 2019
Messages
89
Location
Pennsylvania
My guess, knowing Chryslers of that vintage, is that you have a ground problem. Our old 2003 Town and Country had issues with the fog light wiring. It turned out one of the main grounds under the hood came apart from corrosion. Chrysler uses these small connections at the ground eyelets that develop the green crusties and fall apart. If you can find a wiring diagram, I bet you will learn that the power locks and ABS share a ground somewhere.

It may also be worth starting with the battery and it’s connections. Lots of weird things can stem from there and it’s an easy place to start.
 

HOTPIG175

Thread starter
Joined
Nov 21, 2021
Messages
11
Location
New Zealand
Hey,

Thanks so much for that.
Yep, once I've got this surgery out of the way, I'll take a crack at that.
Starting from the battery makes sense, too, as I seem to recall that it has an smaller battery fitted than recommended, and it can move around a bit at times. It makes sense to address that and the connections first.
I had a Honda Accord US Wagon that had earth issues, and it was in and out of the electrical workshop because it wouldn't start - after solenoids and starter motors were replaced, it turned out that it ws a flood car, and there was a corroded earthe connection in the engine bay.
Grrr!
There is a wiring diagram, (actually, several of them), in the 4000+ page service manual - I just have to work out which one is applicable. Will give me something to do post-op.
Will advise what happens with this poor old thing.
Thanks again,

Andy
 

HOTPIG175

Thread starter
Joined
Nov 21, 2021
Messages
11
Location
New Zealand
I think you just have a bad door position switch.
Hi,

Thanks for responding.
That sounds like a reasonable scenario for the rear lock problem. I dunno about the ABS and Traction Control, but they don't always occur at the same time...
If it has such a thing as a door position switch, I think it's part of the latch mechanism in the door, and, as far as I recall, they are not servicable. I imagine I will have to source a new one, but I'll have to get the thing apart to get the right part number.
It's weird that nobody I spoken to in the last 12 months or so has ever heard of this issue, even on the PT Cruiser forums.
yet another haunted Chrysler product.
Bring back the old tech, sez me!

Thanks for your response, much appreciated.

Andy
 
Top