Cartridge oil filters

Joined
Mar 26, 2009
Messages
408
Location
Ind
I have a question regarding cartridge oil filters. I have one on my toyota corolla. Does a cartridge filter setup have an anti drainback valve?
 
Last edited:

toyotaguy

Thread starter
Joined
Mar 26, 2009
Messages
408
Location
Ind
2009 Toyota corolla. Reason I ask, cause at times when I start the car in the morning, I get a chatter for a few seconds. Not sure if its a timing chain tension or an oil related issue. If I turn the key to turn the engine over, but not start it, then start it it doesn't happen.
 
Joined
Apr 5, 2004
Messages
9,427
Location
Pensacola & Vero Beach FL
 Originally Posted By: ARCOgraphite
Cartridge on a Corolla? Really? Ive seen the v6 cartridge but not the corolla (yet) Please expound. What year?
Yep, the new 1.8L Corollas have a cartridge setup. I hope it's not as bad a PITA as the one on my wife's Avalon.
 

Bill in Utah

Staff member
Joined
Nov 11, 2002
Messages
12,848
Location
UT
From what I've seen they did not improve the filter over the 1ZZFE which is one of the easiest setups in the world. It is more work and make sure you get the o-rings correct or you WILL have issues. Since you are running syn you should have no problems (as if you were running ANY SM rated oil). Take the car back to Toyota and let them have it for some testing. Make sure you let them know the oil being used (they may drain it out and refill with bulk to see if it is oil related) Make sure you report back. Bill
 

toyotaguy

Thread starter
Joined
Mar 26, 2009
Messages
408
Location
Ind
I get the noise weather it is dino or synthetic oil. I dont think it has to do with the oil being used. Im just wondering if it is an oil pump matter or what. I have read other people were also getting this. I heard there was a tsb on it
 
Joined
Jun 11, 2002
Messages
688
Location
Fort Smith, AR
toyotaguy ... any leads on that tsb? I have that same irritating start-up chatter on my Sienna, and the dealer says it's normal.
 

toyotaguy

Thread starter
Joined
Mar 26, 2009
Messages
408
Location
Ind
I'm still looking into that. I am going to call the dealer on monday. You know how TSB's go. I saw this info on a toyota forum It sounds like a timing chain or somthing with it.
 
Last edited:

toyotaguy

Thread starter
Joined
Mar 26, 2009
Messages
408
Location
Ind
#1 metalbones New TN User Join Date: Apr 2009 Location: Florida, USA Posts: 16 Trader Rating: (0) View metalbones's Photo Gallery Post TSB - Engine Knock/Rattle/Squeak on Cold Start Just wanted to give everyone a heads up about this. My car had made a squealing/rattle sound for about a second on a cold start: I ignored it because it only happened once. For the past two days my car has done it every cold start (a total of 5 times) so I decided to take it in to the dealership. I told the tech I thought it may be the belt and/or tensioner and he agreed it was likely. I took my loaner car (downgrade to base model Corolla ) and went about my day, he assured me it should be done by early afternoon. After 4 hours I decided to call that is when I got the news that there is a TSB out for my issue and I would be without my car for 4-5 days because they do not have the parts in stock. I had him print out the TSB information so that I could relay it to everyone here because I know others were having the same issue. The TSB does not mention a squeal but it may sound like a squeal/knock/rattle/screech/metallic grinding. Apparently this is attributed to an oil leak. T-SB-0087-09 - March 13, 2009 Brief Engine Knock/Rattle Noise at Cold Startup Service Category: Engine/Hybrid System Section: Engine Mechanical Market: USA Applicability: 2009 Corolla - Engine(s): 2ZR. Transmission(s): 4AT, 5MT. VDS(s): BL40E, BU40E. 2009 Matrix - Drive Type(s): 2WD. Engine(s): 2ZR. Transmission(s): 4AT, 5MT. VDS(s): KU40E Introduction: Immediately following a cold soak startup, some 2009 model year Corolla and Matrix vehicles may exhibit a brief knock/rattle noise from the engine compartment for approximately one second. Follow the repair procedure below to address customer concerns. Parts Information: Previous Part Number: 13050-0T010. Current Part Number: Same. Part Name: Gear Assembly, Camshaft Timing. Qty: 1. Previous Part Number: 11213-37020. Current Part Number: Same. Part Name: Gasket, Cylinder Head Cover. Qty: 1. Previous Part Number: 11159-37010. Current Part Number: Same. Part Name: Gasket, Camshaft Bearing Cap Oil Hole. Qty: 2. Previous Part Number: 13552-0T020. Current Part Number: Same. Part Name: Gasket, Timing Chain Tensioner. Qty: 1. Warranty Information: OP Code: EG9006. Description: R & R Camshaft Timing Gear Assembly. Time: 1.5. OFP: 13050-0T010. T1: 06. T2: 40. Applicable Warranty: This repair is covered under the Toyota Powertrain Warranty. This warranty is in effect for 60 months or 60,000 miles, whichever occurs first, from the vehicle's in-service date. Warranty application is limited to correction of a problem based upon a customer's specific complaint. Well there it is, sorry for the long story to start. My car will be at the dealer until Tuesday but I will post an update once I get it back and run it for a few days. If you are having a similar issue I would take it in to be checked soon. metalbones is offline Reply With Quote
 
Top