Allison 1000 - P0847

D60

Joined
Nov 6, 2017
Messages
764
Location
Colo
I need to address this '08 GMC/LMM/Ally 1000. Present mileage is around 140k

Symptoms are essentially limp mode and a P0847.....which reads as Circuit B in my Autel (this code seems a bit tricky as in earlier years it was seemingly sometimes Circuit D???).

I have not yet experienced this but the owners tell me in Tow/Haul the symptoms are not present -- does this make sense? I'm wondering if it's just coincidence.

I was finally able to lay hands on it today and wanted to inspect the wiring harness before contemplating a parts order. Sure, enough, the plug was soaked with ATF both externally and internally.

Furthermore, the heat shield was missing the rear bolt and the harness had been chafing on the shield a bit. I did find a solid blue wire that had worn through the insulation. It's weird as I'm the only one who has serviced this truck since ~30k miles so I'm not sure how the rear bolt went missing.

Anyway, I'd love to hear suggestions on a course of action from here. Specifically would you just replace solenoid B and the wiring harness? Or all the solenoids and the wiring harness? Can I test circuit B with mere-mortal tools?

Chafed wire and finger indicates missing bolt location:
20220329_125553.jpg
20220329_125630.jpg
 
Joined
Dec 19, 2013
Messages
6,605
Location
Fort Worth, Texas
DTC P0847 Transmission Pressure Switch 2 Circuit Low

DTC P0847 sets when shift solenoid 2 (SS2) is commanded OFF and PS2 status remains ON for 2–16 seconds, depending on fluid temperature.

Looks like the PS2 output circuit was shorted to ground (It's a Dark Blur wire), This will make the TCM think SS2 is "ON" but in reality it isn't. Block diagram below with the PS2 output circuit highlighted.

Repair shield mounting, Clean external harness & connecter with Alcohol or electrical cleaner, Seal the chaffed spot with some liquid electrical tape, Tape up the harness with some good electrical tape. 3M super 33 preferred.
If the Corrugated Loom is rotted replace it, Then wrap the Loom in Tesa 51036....This tape has outstanding chaffing resistance.

The Internal Harness needs replaced as it's leaking ATF, I don't see any reason to replace any internal switches or solenoids!

TBYBSV4.png
 
  • Like
Reactions: D60

D60

Thread starter
Joined
Nov 6, 2017
Messages
764
Location
Colo
Thank you @clinebarger

I'll just get an internal harness ordered to stop the leak. And yeah, externally, the plastic loom was severely deteriorating and electrical tape under that had been worn thru also. All the plastic retaining clips for the harness were disconnected.

It seems odd to me they tried to use this relatively flimsy heat shield as an exhaust hanger. I think it's the exhaust putting stress on everything. These exhaust systems really do not give due to diameter.

Is it SOP to worry about static when installing the harness (or solenoids) within the tx? Should I wear a bracelet?
 

D60

Thread starter
Joined
Nov 6, 2017
Messages
764
Location
Colo
I'm having some difficulty finding the '06-10 harness 29543336

How is the Rostra or Pioneer stuff thru RA for wiring? Junk?

Do you have a recommended source?
 
Top