99 Malibu 2.4l long crank time to sometime start

Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
any ideas on what to check with a 1999 Malibu 2.4l 4 cylinder with 190K miles that was running fine then would crank but not start. had it towed and they said it fired right up after taking off wrecker. I went ahead and had them install a new fuel pump since my gauge hasn't worked in forever and have never changed original pump. went to get car and it took 4 very long crank sessions to start. drove to gas station and filled up tank. after a few long cranks it started again. got it home and long cranks to start. next morning just tested it and it started right up. did not drive it that day. next day cranked for a while but would not start. no check engine light while it is running. within last two months i have changed out a coil pack and all spark plug boots and all plugs due to missing and check engine light code said misfire bank 2 i believe. since replacing coil and plugs and boots it ran great. any ideas on what to check? I plan to replace plugs again just to inspect them and its easy to do.
 
Joined
Apr 17, 2012
Messages
3,159
Location
Boston, MA
Originally Posted By: Bud_One
Oil pressure switch ? Fuel pressure regulator ?
+1 Do you mean 2.2 instead of 2.4? I don't believe they put the 2.4 in the Malibu until later. What kind of plugs did you use? Brand?
 

Arctic388

Thread starter
Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
yes its the 2.4 in my car. I am pretty sure i used the NGK V-Power spark plug but will have to verify when i remove them. was thinking about going to a Autolite double platinum plug. I have had car since 2000 with 32K on it and have changed the fuel pressure regulator a very long time ago when it was leaking. it is not leaking now. is there a way to test it or just change it? is there a way to test oil pressure switch? will have to study on that one. never messed with it.
 
Joined
Mar 31, 2010
Messages
5,709
Location
Iowa
Originally Posted By: Bgallagher
Originally Posted By: Bud_One
Oil pressure switch ? Fuel pressure regulator ?
+1 Do you mean 2.2 instead of 2.4? I don't believe they put the 2.4 in the Malibu until later. What kind of plugs did you use? Brand?
The 2.4 OP is referring to was the next iteration of the 2.3 Quad 4. OP- do you have any warranty repair records on this car? A defective oil pump will cause this problem. At cranking it can over pressurize the system and hang valves open slightly. The one I did a few years back would peg a 100lb gauge when turned over. Most were fixed under warranty though. It's important to run the specified 5w-30 only in these. I suppose to be technical- the one I worked on had a leaking head gasket, which gooped the oil up, which made the pressure relief valve stick. Timing sets were also problematic. The tensioner would fail and let the timing chain jump. Less likely- can you check the crank sensor? Some scan tools will read RPM. If you have one that will, see if it shows RPM while cranking.
 

Arctic388

Thread starter
Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
i don't have any warranty records on the first year but know since then nothing has been done under warranty. the only thing ever changed was alternator, fuel pressure regulator, the plastic coolant neck off engine and now fuel pump that i asked them to change. I am using Pennzoil Ultra 5w30. i have been using syn since around 90K. then ending has never had any work done on it internally. I have a scanner that i use with the Torque app but don't know if it will read cranking RPM but i will try. this weekend i plan to change/inspect the plugs and change the fuel filter, i forgot to get shop to do this while they had it, and change the oil and filter and check air box. i just checked filter a couple months ago and it looked good. *would the crank position sensor throw a code?
 
Last edited:
Joined
Jun 15, 2003
Messages
36,940
Location
ME
If your fuel pump relay is shot sometimes you need the oil pressure switch to activate the pump. Do you hear the whine from the rear, key on, engine off?
 

Arctic388

Thread starter
Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
this morning i tried to listen for it and heard it click and what sounded like running then maybe not. I will have to verify once the weather clears up some. we have had rain and storms for a couple days.
 
Joined
Jun 15, 2003
Messages
36,940
Location
ME
Is there passlock security on this year? Later years (2004 ish) have it and it's legendarily awful.
 

Arctic388

Thread starter
Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
Originally Posted By: eljefino
Is there passlock security on this year? Later years (2004 ish) have it and it's legendarily awful.
I am pretty sure mine does not have this.
 
Joined
Dec 24, 2009
Messages
3,181
Location
Ohio
Did you replace the white plastic tower that holds the coil packs? Also, sometimes aftermarket fuel pumps bleed down quickly and cause a long crank. You may want to hook up a fuel pressure gauge and verify it holds fuel pressure longer than 5 minutes.
 

Arctic388

Thread starter
Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
i did not replace plastic coil holder. i replaced one coil and actually ordered another but haven't swapped it in yet as it was running fine with just the one coil replaced. plan to put the other in this weekend.
 

Arctic388

Thread starter
Joined
Aug 15, 2005
Messages
381
Location
Southern Middle Tennesee
I'm pretty sure I have found problem. That $&*(%$=^*'"":=-+"'<<&$-< theft light When it is on it won't start. When it's off it fires right up. I never knew it had the worthless theft carp on it. How do I fix that?
 

Bud_One

Site Donor 2021
Joined
Apr 19, 2014
Messages
2,171
Location
Spring,Texas
Originally Posted By: Arctic388
I'm pretty sure I have found problem. That $&*(%$=^*'"":=-+"'<<&$-< theft light When it is on it won't start. When it's off it fires right up. I never knew it had the worthless theft carp on it. How do I fix that?
Is your key worn down showing brass color vs silver? Get a new key cut off your VIN # or key code. My neighbors 98 Chevy Suburban would do that.. they had a spare key that had never been used and it worked fine , where the old used key wouldn't let the vehicle start. Passlock system on your vehicle is not the same the Passkey systems that have a PKIII or PKII on the keys, which have to be programmed.
 
Top