2013 6.7 F350 Delo 5w40 7500mi

Status
Not open for further replies.
Joined
Dec 19, 2013
Messages
7,189
Location
Fort Worth, Texas
Do you do a lot of stop & go driving, Long idle time? How often are the regen's, DPF regeneration requires extra fuel to be injected in the cylinder that will dilute the oil with fuel
 

dnewton3

Staff member
Joined
May 14, 2007
Messages
9,749
Location
Indianapolis, IN
Wear isn't terrible, but the Al uptick is perplexing. Other parameters not bad either. I don't really know what you'd run a syn at those short OCIs ... The fuel dilution is the issue here; no syn is going to stop that. This rig accumulates a lot of miles; probably will have 40k in a year's time? Question is this: what kind of service does it see? If it idles a lot, that would explain the dilution from (likely) frequent regens. If this rig hauls loads on open roads often, coming up to temp and staying under load, then I'd worry about a leaking injector.
 
Last edited:
Joined
May 13, 2013
Messages
1,238
Location
upstate NY
I believe this was your first go 'round with the delo (?).... but wow it looks just like lubrication engineers oil used previously (speaking of the add pack). Maybe the aluminum spike was due to change in oil chemistry (?) Have you talked to or read about other 6.7 owners having the same fuel dilution issue? If you're working it, seems as though it shouldn't regen too much. So I wonder if it is maybe an injector related problem.
 

BeerCan

$50 Site Donor
Thread starter
Joined
Jan 8, 2007
Messages
2,349
Location
TN
Truck does not idle long. It is used as a DD but I often tow heavy. Regens are sometimes every 100 mile and sometimes every 400 but avg around 150-180. I often use B5-B20 so that contributes to fuel dilution I am sure. I have now switched to delo 15w-40 to save some cash I have an appt with the dealer to check the injectors, I will report back with the findings. What perplexes me about the Al is that Polaris reported my Ecoboost doing the same exact thing EB UOA Al shot up on 1 report and then went back down the next. Strange coincidence I hope.
 
Last edited:
Status
Not open for further replies.
Top