1995 Voyager van won't stay running.

Joined
Aug 18, 2004
Messages
3,392
Location
Raleigh ,NC
1995 3.0. It sat for a few weeks and when I went to drive it yesterday it would start and run for maybe 2-3 seconds and then die. Fuel pump pumps up, fresh gas. I'm thinking a sensor is either dead or does not like something and it shuts it down. Any help or thoughts would be most appreciated.
 
Joined
Dec 11, 2009
Messages
973
Location
Battle Creek, MI
Possibly some water collected in the tank after sitting from the ethanol? I know you said fresh gas but the first thing the fuel pump could have pulled was water causing it to run then stall. Just a thought.
 
Last edited:
Joined
Jun 15, 2003
Messages
36,984
Location
ME
These have an "auto shut down relay". Switch with another with the same part number, IIRC, the horn relay.
 
Joined
Dec 27, 2009
Messages
5,914
Location
Tn.
sat 3 weeks, look for water in gas, run stabil, its a cheap fix, cross fingers and burn some buffalo chips at 3 am. No, really, the stabil is your cheap fix. It has worked for me. Forget the chips for now.
 
Joined
Feb 6, 2014
Messages
3,897
Location
Canada
it's a 95 Voyager...let it die. It's lived a long life. Time for it to go onto that big junkyard in the skiy
 
Joined
Sep 23, 2007
Messages
8,598
Location
Florida
Failing distributor? They are a common weak point in 1990s Japanese engines. It is important to get a new one, rebuilds are good for about 1 year.
 
Joined
Dec 10, 2002
Messages
9,367
Location
USA
Call me superstitious but a car that old should not be sitting and be driven regularly. I read over and over old cars that sit for weeks do not start back up again after running fine.
 
Joined
Jan 22, 2011
Messages
6,028
Location
Ohio
Does it have an EGR valve? Sometimes they hang open and the engine will run badly especially at cold and idle. If your engine has one, try tapping it with a hammer and restart.
 
Last edited:
Top