03 escort, ZX2, hard on oil?

Joined
Oct 6, 2008
Messages
1,589
Location
NC
Quick question, my little brother just bought this car with low miles on it and i told him i would post this question. Is this car generally hard on oil? I know some are worse than others. We drained the 10w40 that the small dealership put in when they serviced it and went with the factory recommended 5w20. QS Horsepower 18 bucks at WM. I kinda think some places put the heavier oils in just to quite down the engines a little or reduce oil burning if there was an issue. That was just a side note.
 
Joined
Sep 8, 2005
Messages
15,229
Location
Canada
Not at all. Good you got the proper visc. in there - but doesn't that engine call for 5W-30? Buddy had a 1998 ZX2, and it took 5W-30...
 
Joined
Jul 19, 2009
Messages
2,053
Location
Detroit, MI
5w20 I'm pretty sure. I had a Focus ZX3 with that Ztec engine, and my gf's contour also has that engine. 2.0l dohc. I can tell you that they tend to be loud, and some of the older ones really started to vibrate pretty bad as they get older. Her car has 144k on it, it still still runs well, but I do notice it is pretty noisey, and the oil always looks bad lol
 

jstutz

Thread starter
Joined
Oct 6, 2008
Messages
1,589
Location
NC
It is most def. 5w20, they probably just changed the oil caps somewhere around 01 or something. I read that it is important to use the correct viscosity due to variable timing. Anyway i would have not cared if the guy used 5w30, but 10w40.. Really! Im all about using thicker oils if it is needed but in this case i feel like that was a little extreme. Also this little car has some idle vibration that i guess is just its nature due to poor engine mount designs.
 

rat

Joined
Dec 10, 2006
Messages
361
Location
Michigan
The vibration at idle is normal, especially in an automatic. I use 5W20 Havoline in my 99 ZX2 5spd and love how smooth and quiet it runs.
 
Last edited:
Top