03 Escape heater control valve

Messages
5,928
Location
Waterloo, ON
The temperature control on my 03 Escape has stopped working. The control is a plastic rotary knob that is broken due to the force needed to move the temp control. Have to use pliers its so stiff. I have taken apart the control and nothing is seized or broken. There are 2 cables that go down and disappear into the dash area. Do these cables go to a heater control valve or a blend door? My guess it that is what has gone bad is the water vales, but it is buried far into the dash and out of sight.
 

Bluestream

Thread starter
Messages
5,928
Location
Waterloo, ON
So, there is an electric motor that controls the blend door? When I had the dash unit apart there were cables that I assumed went down to a heater valve or blend door.
 
Messages
15,573
Location
Santa Barbara, CA
The cables go to the temperature blend door, no electric motor on this year. The cables are serviced together and can only go one place. The middle knob is vacuum so there will be no confusing that.
 

Bluestream

Thread starter
Messages
5,928
Location
Waterloo, ON
Not sure if oil will help here... I have the control working, but it it will only move to the "cool" position and then it stops 3 notches from end position as shown in the pic. Any attempt to move it past this position will break the plastic knob. (even pliers will not move it more to the left) This temp control is not the smooth moving type, but have a "click stop" at each position on the bezel. (indicative of a cable operated design) It will move all the way to the hot position without problem. Could this be a kinked cable.
 
Last edited:
Top